Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2679

ClearCase error while creating view.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: clearcase-plugin
    • Labels:
      None
    • Environment:
      Platform: Other, OS: Windows XP
    • Similar Issues:

      Description

      Hi I am using Hudson with ClearCase from past 6 months. Initially I was able to
      use it with no problem, but few days back I got the below error message and not
      able find the reason and solution for it, but couldn't. After changing some
      variables it started working and couldn't find the reason how the build started.
      Can someone help me who is using Hudson with ClearCase why the below error
      comes and How to overcome it.

      started
      [workspace] $ cleartool mkview snapshot -tag Sekhar01 -vws
      vlrcc007

      vb\test_cc_views\INDIA\R00702689\R80TYC020.vws BI01
      cleartool: Error: unable to create directory
      vlrcc007-
      vb\test_cc_views\INDIA\R00702689\R80TYC020.vws: Access is denied.
      cleartool: Error: Unable to create directory "
      vlrcc007-
      vb\test_cc_views\INDIA\R00702689\R80TYC020.vws": Permission denied.
      cleartool: Error: Unable to create view "
      vlrcc007-
      vb\test_cc_views\INDIA\R00702689\R80TYC020.vws".
      FATAL: Base ClearCase failed. exit code=1
      FATAL: cleartool did not return the expected exit code. Command line="mkview -
      snapshot -tag Sekhar01 -vws \\vlrcc007-vb\test_cc_views\INDIA\R00702689
      \R80TYC020.vws BI01", actual exit code=1
      java.io.IOException: cleartool did not return the expected exit code. Command
      line="mkview snapshot -tag Sekhar01 -vws
      vlrcc007

      vb\test_cc_views\INDIA\R00702689\R80TYC020.vws BI01", actual exit code=1
      at hudson.plugins.clearcase.HudsonClearToolLauncher.run
      (HudsonClearToolLauncher.java:72)
      at hudson.plugins.clearcase.ClearToolSnapshot.mkview
      (ClearToolSnapshot.java:53)
      at hudson.plugins.clearcase.action.SnapshotCheckoutAction.checkout
      (SnapshotCheckoutAction.java:43)
      at hudson.plugins.clearcase.AbstractClearCaseScm.checkout
      (AbstractClearCaseScm.java:199)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:666)
      at hudson.model.AbstractBuild$AbstractRunner.checkout
      (AbstractBuild.java:261)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:235)
      at hudson.model.Run.run(Run.java:817)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:204)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:90)

        Attachments

          Activity

          rajsekhar_nukala06 rajsekhar_nukala06 added a comment -

          ClearCase error creating a view. access denied

          sunfire sunfire added a comment -

          Looks like some kind of permissions issue (either filesystem or ClearCase vob).
          What dig you do to make it work again? Have you checked with admins about
          permission changes?

          rajsekhar_nukala06 rajsekhar_nukala06 added a comment -

          \\vlrcc007-vb\test_cc_views\INDIA\R00702689(R80TYC020.vws)

          from the above line,I tried changing the last section(highlighted in braces) as
          R80TYC020.vws,R80TYC021.vws etc and along with that I changed the view name
          section in Hudson. After sometime when tried to Build, I am able to get the
          Code and the build started. There were no permission changes, If any Admin
          would have Informed me about the same.

          sunfire sunfire added a comment -

          Can't reproduce this, anyone with this problem?

          rajsekhar_nukala06 rajsekhar_nukala06 added a comment -

          Hi, I solved the ClearCase View Creation Issue.

          Solution is so simple. Just open Apache Tomcat Properties and goto Logon and
          select Logon as and provide your inputs. This will work fine.


            People

            • Assignee:
              sunfire sunfire
              Reporter:
              rajsekhar_nukala06 rajsekhar_nukala06
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: