Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26818

Test result trends not showing in sectioned dashboard view

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: sectioned-view-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      The sectioned dashboard does not appear to be displaying any graphs. I'm expecting to see the test trends graph that is displayed on the actual jenkins build (unit-test).

      It would also be great if it displayed the cobetura code coverage graph too, but understand if that's an enhancement request rather than a bug.

      I have this working on a different Jenkins rig where it is displaying the test trend graphs and really like the style of the dashboard that this plugin provides ... but just can't seem to get it working on this rig.

      I've added a dashboard with a Job Graphs Section and a Test Result Section. Both seem to be empty other than links to the actual jobs. Screenshots attached.

      Any idea what might be going on?

      Let me know if you need more diags - I've included a list of the installed plugins in the environment box above.

        Attachments

        1. img1.png
          img1.png
          163 kB
        2. img2.png
          img2.png
          99 kB

          Activity

          stuckert Ralf Stuckert added a comment -

          Very similar here: all other graphs (checkstyle, task, etc) but test trends are visualized. Test trends are shown neither in the job graphs nor in the dedicated test results section. In the test result section only the name is shown. I'm using free style jobs and the test result publisher to show the trend on the job's view.

          ekrutikhin Egor Krutikhin added a comment - - edited

          The cause of bug is in using "job.actions" property in jelly scripts https://github.com/jenkinsci/sectioned-view-plugin/blob/master/src/main/resources/hudson/plugins/sectioned_view/TestResultViewSection/main.jelly and https://github.com/jenkinsci/sectioned-view-plugin/blob/master/src/main/resources/hudson/plugins/sectioned_view/JobGraphsSection/main.jelly. In new versions of Jenkins the result of such property doesn't contain TestResultProjectAction item. Instead of "job.actions" it should be "job.allActions".

          I've patched these 2 files inside of plugin's jar and it seems to be fixed. It works for me now.

          markc Mark Cariddi added a comment - - edited

          I made that fix and it worked for me, but I found another issue. If I add a test trends section for test X with some items in it, and then add another test trends section for Test Y with some items, the items for section X disappear. Looks like you can only have one test trends section. Just to be clear I am talking about the JobsGraphSection view, the one that shows junit results.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Oliver Gondža
          Path:
          src/main/java/hudson/plugins/sectioned_view/SectionedView.java
          src/test/java/hudson/plugins/sectioned_view/TestResultViewSectionTest.java
          src/test/resources/hudson/plugins/sectioned_view/junit-report-1472.xml
          http://jenkins-ci.org/commit/sectioned-view-plugin/ea4569dcf8b1513123923602ed0b09ed528d858d
          Log:
          JENKINS-26818 Reproduce in unittest

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Andrey Adamovich
          Path:
          pom.xml
          src/main/resources/hudson/plugins/sectioned_view/JobGraphsSection/main.jelly
          src/main/resources/hudson/plugins/sectioned_view/TestResultViewSection/main.jelly
          http://jenkins-ci.org/commit/sectioned-view-plugin/e4628c8574bcdafe4008626ef2f9cbc6ea06803b
          Log:
          [FIXED JENKINS-26818] fixed issues with test trend display and upgraded to latest jenkins


            People

            • Assignee:
              andrey_adamovich Andrey Adamovich
              Reporter:
              robbrockbank Rob Brockbank
            • Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: