Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26895

Exception if Dashboard View plugin is not installed

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: release-plugin
    • Labels:
      None
    • Environment:
      jenkins 1.598
      copyartifact plugin 1.34
    • Similar Issues:

      Description

      I have this excpetion in the logs. I am assuming it comes from the copyartifact plugin from the backtrace

      Feb 11, 2015 8:13:20 AM WARNING hudson.ExtensionFinder$GuiceFinder$SezpozModule configure
      Failed to load hudson.plugins.release.dashboard.RecentReleasesPortlet$DescriptorImpl
      java.lang.LinkageError: Failed to resolve class hudson.plugins.release.dashboard.RecentReleasesPortlet$DescriptorImpl
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule.resolve(ExtensionFinder.java:491)
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:524)
      at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:253)
      at com.google.inject.spi.Elements.getElements(Elements.java:108)
      at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:135)
      at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      at com.google.inject.Guice.createInjector(Guice.java:96)
      at com.google.inject.Guice.createInjector(Guice.java:73)
      at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:279)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      at java.lang.Class.newInstance(Class.java:379)
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:371)
      at hudson.ExtensionList.load(ExtensionList.java:300)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
      at hudson.ExtensionList.iterator(ExtensionList.java:143)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:364)
      at hudson.ExtensionList.load(ExtensionList.java:300)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
      at hudson.ExtensionList.iterator(ExtensionList.java:143)
      at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1191)
      at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:99)
      at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:386)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:903)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)

        Attachments

          Issue Links

            Activity

            pbor Paolo Borelli created issue -
            ikedam ikedam added a comment -

            I believe this isn't caused by copyartifact as copyartifact doesn't refer dashboard plugin.
            Please report followings:

            • Whole Jenkins startup log.
            • Complete list of plugins you install to Jenkins.
            • From when do you see that error? Did you upgrade Jenkins or any plugins?
            ikedam ikedam made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-20027 [ JENKINS-20027 ]
            ikedam ikedam made changes -
            Link This issue is related to JENKINS-11398 [ JENKINS-11398 ]
            pbor Paolo Borelli added a comment -

            Thanks for the reply. I suspected that copyartifact was not the culprit, but it was the plugin I spotted in the backtrace so I mentioned that in the title.

            Here is the list of plugins installed and the start of the jenkins log up until the point the exception occurs (if you want even more let me know, but it is quite big)

            I am not quite sure when the problem started: I am trying to install the SCM sync plugin and we are having some problems and checking the log I spotted this exception that seems unrelated

            Plugins

            all-changes 1.3 false false
            analysis-core 1.69 true false
            ant 1.2 true true
            antisamy-markup-formatter 1.3 true true
            changes-since-last-success 0.5 true false
            checkstyle 3.41 true false
            cobertura 1.9.6 true false
            conditional-buildstep 1.3.3 true false
            config-file-provider 2.7.5 true false
            copy-to-slave 1.4.3 true false
            copyartifact 1.34 true false
            credentials 1.22 true true
            custom-job-icon 0.2 true false
            custom-tools-plugin 0.4.4 true false
            cvs 2.12 false true
            depgraph-view 0.11 true false
            description-setter 1.9 true false
            downstream-buildview 1.9 true false
            email-ext 2.39 true false
            envfile 1.2 true false
            extended-choice-parameter 0.34 true false
            external-monitor-job 1.4 true false
            favorite 1.16 true false
            findbugs 4.59 true false
            git 2.3.4 true false
            git-client 1.16.1 true false
            gravatar 2.1 true false
            greenballs 1.14 false false
            htmlpublisher 1.3 true false
            ivy 1.24 true false
            jacoco 1.0.18 true false
            javadoc 1.3 true true
            jenkins-tag-cloud-plugin 1.6 true false
            jquery 1.7.2-1 true false
            jquery-ui 1.0.2 true false
            junit 1.4 true true
            ldap 1.11 true true
            mailer 1.15 true true
            mapdb-api 1.0.6.0 true false
            matrix-auth 1.2 true true
            matrix-project 1.4 true true
            maven-plugin 2.8 true true
            memegen 0.4.3 true false
            multiple-scms 0.3 true false
            next-build-number 1.1 true false
            nodelabelparameter 1.5.1 true false
            pam-auth 1.2 true true
            parameterized-trigger 2.25 true false
            pending-changes 0.3.0 true false
            pmd 3.40 true false
            promoted-builds 2.19 true false
            publish-over-cifs 0.3 true false
            publish-over-ftp 1.11 true false
            publish-over-ssh 1.12 true false
            release 2.4.1 true false
            run-condition 1.0 true false
            saferestart 0.3 true false
            scm-api 0.2 true false
            scm-sync-configuration 0.0.8 true false
            scp 1.8 true false
            script-security 1.13 true false
            setenv 1.1 true false
            shelve-project-plugin 1.5 true false
            slave-status 1.6 true false
            sloccount 1.20 true false
            ssh 2.4 true false
            ssh-agent 1.5 true false
            ssh-credentials 1.10 true true
            ssh-slaves 1.9 true true
            subversion 2.5 true true
            svn-release-mgr 1.2 true false
            svn-tag 1.17 true false
            svnpublisher 0.1 true false
            template-project 1.4.2 true false
            throttle-concurrents 1.8.4 true false
            token-macro 1.10 true false
            translation 1.12 true true
            URLSCM 1.6 true false
            viewVC 1.7 true false
            violations 0.7.11 true false
            warnings 4.45 true false
            windows-slaves 1.0 true false
            ws-cleanup 0.25 true false
            xshell 0.10 true false

            Feb 12, 2015 10:37:06 AM INFO winstone.Logger logInternal
            Winstone Servlet Engine v2.0 running: controlPort=disabled
            Feb 12, 2015 10:37:07 AM INFO jenkins.InitReactorRunner$1 onAttained
            Started initialization
            Feb 12, 2015 10:37:07 AM INFO hudson.ClassicPluginStrategy createPluginWrapper
            Plugin greenballs.jpi is disabled
            Feb 12, 2015 10:37:07 AM INFO hudson.ClassicPluginStrategy createPluginWrapper
            Plugin cvs.jpi is disabled
            Feb 12, 2015 10:37:09 AM INFO hudson.ClassicPluginStrategy createPluginWrapper
            Plugin all-changes.jpi is disabled
            Feb 12, 2015 10:37:09 AM INFO jenkins.InitReactorRunner$1 onAttained
            Listed all plugins
            Feb 12, 2015 10:37:15 AM INFO hudson.plugins.memegen.PluginImpl start
            starting memegen plugin
            Feb 12, 2015 10:37:18 AM INFO com.youdevise.hudson.slavestatus.SlaveListenerInitiator init
            Initialising slave-status plugin
            Feb 12, 2015 10:37:18 AM INFO jenkins.InitReactorRunner$1 onAttained
            Prepared all plugins
            Feb 12, 2015 10:37:22 AM WARNING hudson.ExtensionFinder$GuiceFinder$SezpozModule configure
            Failed to load hudson.plugins.release.dashboard.RecentReleasesPortlet$DescriptorImpl
            java.lang.LinkageError: Failed to resolve class hudson.plugins.release.dashboard.RecentReleasesPortlet$DescriptorImpl
            at hudson.ExtensionFinder$GuiceFinder$SezpozModule.resolve(ExtensionFinder.java:491)
            at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:524)
            at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
            at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:253)
            at com.google.inject.spi.Elements.getElements(Elements.java:108)
            at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:135)
            at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
            at com.google.inject.Guice.createInjector(Guice.java:96)
            at com.google.inject.Guice.createInjector(Guice.java:73)
            at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:279)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
            at java.lang.Class.newInstance(Class.java:379)
            at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
            at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
            at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
            at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:371)
            at hudson.ExtensionList.load(ExtensionList.java:300)
            at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
            at hudson.ExtensionList.iterator(ExtensionList.java:143)
            at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:364)
            at hudson.ExtensionList.load(ExtensionList.java:300)
            at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
            at hudson.ExtensionList.iterator(ExtensionList.java:143)
            at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1191)
            at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:99)
            at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
            at hudson.PluginManager$2$1$2.run(PluginManager.java:386)
            at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
            at jenkins.model.Jenkins$7.runTask(Jenkins.java:903)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            at java.lang.Thread.run(Thread.java:745)
            Caused by: java.lang.TypeNotPresentException: Type hudson.plugins.view.dashboard.DashboardPortlet not present
            at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:117)
            at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Reifier.java:125)
            at sun.reflect.generics.tree.ClassTypeSignature.accept(ClassTypeSignature.java:49)
            at sun.reflect.generics.visitor.Reifier.reifyTypeArguments(Reifier.java:68)
            at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Reifier.java:138)
            at sun.reflect.generics.tree.ClassTypeSignature.accept(ClassTypeSignature.java:49)
            at sun.reflect.generics.repository.ClassRepository.getSuperclass(ClassRepository.java:84)
            at java.lang.Class.getGenericSuperclass(Class.java:701)
            at hudson.ExtensionFinder$GuiceFinder$SezpozModule.resolve(ExtensionFinder.java:476)
            ... 37 more
            Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
            at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
            at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
            at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:274)
            at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:114)
            ... 45 more

            Feb 12, 2015 10:37:31 AM INFO jenkins.InitReactorRunner$1 onAttained
            Started all plugins
            Feb 12, 2015 10:37:32 AM INFO jenkins.InitReactorRunner$1 onAttained
            Augmented all extensions
            Feb 12, 2015 10:37:33 AM INFO hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness queueChangeSet
            Queue of changeset A hudson.model.UpdateCenter.xml
            aborted (scm manipulator not settled !)
            Feb 12, 2015 10:37:33 AM INFO hudson.plugins.copyartifact.CopyArtifact setUpgradeNeeded
            Upgrade for Copy Artifact is scheduled.
            Feb 12, 2015 10:37:44 AM INFO jenkins.InitReactorRunner$1 onAttained
            Loaded all jobs
            Feb 12, 2015 10:37:44 AM WARNING hudson.plugins.copyartifact.CopyArtifact upgradeCopyArtifact
            Update of CopyArtifact is scheduled, but no CopyArtifact to upgrade was found!
            Feb 12, 2015 10:37:45 AM INFO org.jenkinsci.main.modules.sshd.SSHD start
            Started SSHD at port 58125
            Feb 12, 2015 10:37:45 AM INFO jenkins.InitReactorRunner$1 onAttained
            Completed initialization
            Feb 12, 2015 10:37:47 AM INFO org.springframework.web.context.support.StaticWebApplicationContext prepareRefresh
            Refreshing org.springframework.web.context.support.StaticWebApplicationContext@501ff9c: display name [Root WebApplicationContext]; startup date [Thu Feb 12 10:37:47 CET 2015]; root of context hierarchy
            Feb 12, 2015 10:37:47 AM INFO org.springframework.web.context.support.StaticWebApplicationContext obtainFreshBeanFactory
            Bean factory for application context [org.springframework.web.context.support.StaticWebApplicationContext@501ff9c]: org.springframework.beans.factory.support.DefaultListableBeanFactory@7c20ada9
            Feb 12, 2015 10:37:47 AM INFO org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
            Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@7c20ada9: defining beans [initialDirContextFactory,bindAuthenticator,ldapUserSearch,authenticationManager,authoritiesPopulator]; root of factory hierarchy
            Feb 12, 2015 10:37:47 AM INFO org.acegisecurity.ldap.DefaultInitialDirContextFactory setProviderUrl
            URL 'ldap://172.16.10.23:389/ou=People,dc=nice', root DN is 'ou=People,dc=nice'
            Feb 12, 2015 10:37:47 AM INFO org.acegisecurity.ldap.search.FilterBasedLdapUserSearch
            SearchBase not set. Searches will be performed from the root: ou=People,dc=nice
            Feb 12, 2015 10:37:47 AM INFO org.acegisecurity.providers.ldap.populator.DefaultLdapAuthoritiesPopulator setGroupSearchBase
            groupSearchBase is empty. Searches will be performed from the root: ou=People,dc=nice
            Feb 12, 2015 10:37:47 AM INFO org.springframework.web.context.support.StaticWebApplicationContext prepareRefresh
            Refreshing org.springframework.web.context.support.StaticWebApplicationContext@7d342f07: display name [Root WebApplicationContext]; startup date [Thu Feb 12 10:37:47 CET 2015]; root of context hierarchy
            Feb 12, 2015 10:37:47 AM INFO org.springframework.web.context.support.StaticWebApplicationContext obtainFreshBeanFactory
            Bean factory for application context [org.springframework.web.context.support.StaticWebApplicationContext@7d342f07]: org.springframework.beans.factory.support.DefaultListableBeanFactory@6898a972
            Feb 12, 2015 10:37:47 AM INFO org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
            Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@6898a972: defining beans [filter,legacy]; root of factory hierarchy
            Feb 12, 2015 10:37:48 AM INFO hudson.slaves.SlaveComputer tryReconnect
            Attempting to reconnect hudson-ef
            Feb 12, 2015 10:37:48 AM INFO hudson.slaves.SlaveComputer tryReconnect
            Attempting to reconnect macbook
            Feb 12, 2015 10:37:48 AM INFO hudson.slaves.SlaveComputer tryReconnect
            Attempting to reconnect hudson-centos6-physical
            Feb 12, 2015 10:37:48 AM INFO com.youdevise.hudson.slavestatus.SlaveListenerInitiator onOnline
            Starting slave-status listener on
            Feb 12, 2015 10:37:48 AM INFO com.youdevise.hudson.slavestatus.SlaveListener call
            Slave-status listener starting
            Feb 12, 2015 10:37:48 AM INFO com.youdevise.hudson.slavestatus.SocketHTTPListener waitForConnection
            Slave-status listener ready on port 3141

            danielbeck Daniel Beck added a comment -

            Looks more like something may have gone wrong extracting dashboard view. I'd try trashing the folders in JENKINS_HOME/plugins/ while Jenkins is stopped to have it recreate them from jpi's upon next start.

            ikedam ikedam added a comment -

            That looks caused by release-plugin.
            Uninstalling release-plugin or installing dashboard-view plugin should resolve the problem.

            ikedam ikedam made changes -
            Assignee Peter Hayes [ petehayes ]
            Component/s release-plugin [ 15622 ]
            Component/s copyartifact-plugin [ 15692 ]
            ikedam ikedam made changes -
            Link This issue is related to JENKINS-4845 [ JENKINS-4845 ]
            pbor Paolo Borelli added a comment -

            I confirm the execption goes away if I remove the release-plugin

            leandro_freitas_softdevelop Leandro Kersting de Freitas added a comment -

            +1

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 161074 ] JNJira + In-Review [ 180566 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Adrien Lecharpentier
            Path:
            src/main/java/hudson/plugins/release/dashboard/RecentReleasesPortlet.java
            http://jenkins-ci.org/commit/release-plugin/fbf239c96b7baf9a7cc609397bd03077028fcc41
            Log:
            JENKINS-26895 Fix optional dependency check on dashboard-view

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/hudson/plugins/release/dashboard/RecentReleasesPortlet.java
            http://jenkins-ci.org/commit/release-plugin/a11d6a9895431d43a1fed8794d9aac1ccad70670
            Log:
            Merge pull request #28 from alecharp/JENKINS-26895

            JENKINS-26895 Fix optional dependency check on dashboard-view

            Compare: https://github.com/jenkinsci/release-plugin/compare/cf22988f0bee...a11d6a989543

            oleg_nenashev Oleg Nenashev added a comment -

            Adrien Lecharpentier has proposed a fix for this issue.
            It has been released in Release Plugin 2.9

            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                petehayes Peter Hayes
                Reporter:
                pbor Paolo Borelli
              • Votes:
                3 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: