Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26976

Sticky Claim on failed build should persist only if build remains failed (not if it becomes unstable)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Won't Fix
    • Component/s: claim-plugin
    • Labels:
    • Environment:
      Jenkins ver. 1.580.3
      Claim Plugin 2.5
    • Similar Issues:

      Description

      When a developer claims a failed build and checks "Sticky", it means that he will fix the build failure, but not necessarily unit tests failures.

      Claiming a failed build wth "Sticky" option should only persists if the build remains failed and not if it becomes unstable.

        Attachments

          Activity

          jgrant216 Jeff G added a comment -

          I do not agree with this defect. If changed, please make it a (global) configuration point defaulting to the current behavior of remaining stuck if going from fail to unstable or unstable to fail.

          jgrant216 Jeff G added a comment -

          This is a duplicate of JENKINS-15007.

          ki82 Christian Bremer added a comment -

          If you check sticky it would most often mean that you would fix all problems until the build is successful or until you unclaim it.
          Closing this as won't fix, adding a global configuration for it without changing the default behavior could be added as a feature request and I will accept an pull request for it.

          dblanchette Denis Blanchette added a comment -

          In our case, when people check sticky it means that they will fix the problem that they caused, usually compilation problems caused by their code.

          While it may means many things, an unstable build doesn't mean the same thing as a failed build. It is usually not the same people that fixes the code that is commited for a project than those who configure Jenkins and make sure there are no unstable builds.

          Also, if a build is unstable then fails and is claimed, it is not the responsability of the user who broke the build to repair previous issues.

          Just my opinion and I see it is not shared, I might do a pull request for a config change if I find the time.

          Thanks for your answer.

          trejkaz trejkaz added a comment -

          I agree with Denis on this. The reason I no longer claim failed builds is because I know there are failing tests in them and I don't want all those pinned on me as well. Essentially it makes the feature of claiming builds pointless. (We still use claiming for individual tests, though.)


            People

            • Assignee:
              ki82 Christian Bremer
              Reporter:
              dblanchette Denis Blanchette
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: