Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27137

Connection Aborted since 2.5 on Win64

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Since upgrade from 2.3 to 2.5 builds on windows slaves crash during (or shortly after) svn checkout.

      Messages are mostly about connection abort between master and slave.

      The problem arises when upgrading subversion plugin to 2.5.

      The problem never occured using version 2.3 (used for nearly a year).

      The problem did not (yet) arise using version 2.4.5 either (used one day so far).

      Linux slaves (workspace on tmpfs, same os/jre/svn as master) are not affected by this problem.

      The problem (when summing up different stack traces as shown below) seems to be reproducible by 100%.

      CASE 1 : After svn check out , slave dit not get shut down nor disconnected at network layer (remote desktop active all the time!)

      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      hudson.remoting.RequestAbortedException: java.net.SocketException: Connection reset
      at hudson.remoting.Request.abort(Request.java:295)
      at hudson.remoting.Channel.terminate(Channel.java:814)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to WindowsJev2(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      at hudson.remoting.Request.call(Request.java:171)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:959)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:679)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      CASE 2 : After svn check out , despite message slave did NOT go down nor got disconnected on network layer! (remote desktop active all the time!)

      ERROR: POMs konnten nicht geparst werden
      java.io.IOException: remote file operation failed: d:\jws\tools\hudson.tasks.Maven_MavenInstallation\Maven_3.0.4\hudson1843729123396716916.sh at hudson.remoting.Channel@69e40890:WindowsHMJev4: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.FilePath.act(FilePath.java:976)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.FilePath.delete(FilePath.java:1412)
      at hudson.tools.AbstractCommandInstaller.performInstallation(AbstractCommandInstaller.java:82)
      at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:68)
      at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:107)
      at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:205)
      at hudson.tasks.Maven$MavenInstallation.forNode(Maven.java:609)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:627)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:549)
      at hudson.remoting.Request.call(Request.java:129)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      ... 13 more
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
      Looks like the node went offline during the build. Check the slave log for the details.
      details

      FATAL: channel is already closed
      hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:549)
      at hudson.remoting.Request.call(Request.java:129)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.Launcher$RemoteLauncher.kill(Launcher.java:941)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:556)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      CASE 3 : After svn checkout , slave did not go down nor was disconnected on network layer (remote desktop active all the time!)

      Parsing POMs
      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      hudson.remoting.RequestAbortedException: java.net.SocketException: Connection reset
      at hudson.remoting.Request.abort(Request.java:295)
      at hudson.remoting.Channel.terminate(Channel.java:814)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to WindowsJev1(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      at hudson.remoting.Request.call(Request.java:171)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:959)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:679)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      CASE 4 : At the end of svn check out , slave online as always , seen by remote desktop

      no change for http://host.domain.tld/svn/dist/trunk/win32/maven/3.0.3 since the previous build
      FATAL: java.net.SocketException: Connection reset
      hudson.remoting.RequestAbortedException: java.net.SocketException: Connection reset
      at hudson.remoting.Request.abort(Request.java:295)
      at hudson.remoting.Channel.terminate(Channel.java:814)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to WindowsJev2(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      at hudson.remoting.Request.call(Request.java:171)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.scm.SubversionChangeLogBuilder.getUrlForPath(SubversionChangeLogBuilder.java:151)
      at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:135)
      at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
      at hudson.scm.SCM.checkout(SCM.java:488)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1257)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      CASE 5 : Before ending svn checkout , slave online as usual

      Hole 'http://host.domain.tld/svn/dist/trunk/win32/cws/1.0.1' aus Revision -1 in Datei 'D:\xxx\workspace\yyy\build\cws'
      At revision 2810
      At revision 7390
      FATAL: java.net.SocketException: Connection reset
      hudson.remoting.RequestAbortedException: java.net.SocketException: Connection reset
      at hudson.remoting.Request.abort(Request.java:295)
      at hudson.remoting.Channel.terminate(Channel.java:814)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to WindowsJev1(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      at hudson.remoting.Request.call(Request.java:171)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:838)
      at hudson.scm.SCM.checkout(SCM.java:488)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1257)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      CASE 6 : After svn checkout , slave online as usual , error does not occur using previous subversion plugin releases

      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      java.lang.RuntimeException: java.io.IOException: remote file operation failed: d:\xxx\tools\hudson.tasks.Maven_MavenInstallation\Maven_3.0.4\hudson8484916583069804467.sh at hudson.remoting.Channel@538de52e:WindowsHMJev4: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.scm.SubversionSCM.getModuleRoot(SubversionSCM.java:1505)
      at hudson.model.AbstractBuild.getModuleRoot(AbstractBuild.java:308)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:629)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.io.IOException: remote file operation failed: d:\xxx\tools\hudson.tasks.Maven_MavenInstallation\Maven_3.0.4\hudson8484916583069804467.sh at hudson.remoting.Channel@538de52e:WindowsHMJev4: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.FilePath.act(FilePath.java:976)
      at hudson.FilePath.act(FilePath.java:958)
      at hudson.FilePath.delete(FilePath.java:1412)
      at hudson.tools.AbstractCommandInstaller.performInstallation(AbstractCommandInstaller.java:82)
      at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:68)
      at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:107)
      at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:205)
      at hudson.tasks.Maven$MavenInstallation.forNode(Maven.java:609)
      at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:184)
      at hudson.scm.SubversionSCM.getModuleRoot(SubversionSCM.java:1503)
      ... 7 more
      Caused by: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:549)
      at hudson.remoting.Request.call(Request.java:129)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.FilePath.act(FilePath.java:969)
      ... 16 more
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:189)
      at java.net.SocketInputStream.read(SocketInputStream.java:121)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:33)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

        Attachments

          Activity

          recena Manuel Recena Soto added a comment -

          Tim-Christian Bloss, Better if you use Subversion Plugin 2.5.4 (latest)

          tcb_xy Tim-Christian Bloss added a comment -

          We'll evaluate 2.5.4 next week (2015/11/16+) within our scheduled maintenance, running our system integration tests to verify stability.

          We'll also test 2.5 as an intermedia upgrade step, so we can see if this error still occurs on win64.
          That's just to verify if it's an issue regarding our win64 setups (2008r2) or something fixed between 2.5 and 2.5.4, in case 2.5.4 works flawlessy as I hope.

          Best regards

          tcb_xy Tim-Christian Bloss added a comment -

          We had no issues using 2.4.5 in Jenkins 1.596.3 , neither on Windows nor Linux.

          Using 2.5 we got some other errors and issues, both on Linux and Windows.

          Using 2.5.4 no error occured when using Jenkins 1.596.3

          Also no error using 2.5.4 with Jenkins 1.609.3 , neither on Linux nor Windows.

          Summed up: subversion plugin 2.4.5 and 2.5.4 both work with Jenkins 1.596.3 and 1.609.3 on Linux and Windows using Oracle JRE 1.8.0u66(master) and 1.80u25/31/66(slaves).

          Therefore I would suspect our problems using 2.5 results from some specialities, maybe combination of 2.5 and our svn repository version have some incompatibility that was fixed on the way to 2.5.4.

          So I think this case can be closed.

          tcb_xy Tim-Christian Bloss added a comment -

          Hi,

          problem seems to be solved some way between 2.5 and 2.5.4 , though I can't determine what exactly did solve this.
          Maybe some other plugins which got updated in the meantime had side effects, but that can't be investigated anymore.
          After all this issue is no longer of any relevance to us.

          Thank you for having observed it!

          Best regards

          recena Manuel Recena Soto added a comment -

          Tim-Christian Bloss, Thanks so much for your feedback.


            People

            • Assignee:
              recena Manuel Recena Soto
              Reporter:
              tcb_xy Tim-Christian Bloss
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: