Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27213

Recent vsphere-cloud plugin and build-flow plugin versions don't identify any node

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      vsphere-cloud plugin version 2.3
      build-flow plugin version 0.17
      Jenkins build 1.599

      [Java version / OS does not matter]
    • Similar Issues:

      Description

      Steps
      1) Deploy a Jenkins instance from the appropriate war, and get those 2 plugins installed.
      2) Configure a test vcenter, a vsphere cloud slave instance (in my case the configuration was: boot on demand, connect via ssh launcher, shut down when idle after 10 min of idle time).
      3) Tie a job to the slave and kick it off.

      I observe that the build simply sits in queue and never kicks off.

        Attachments

          Activity

          paragdoke Parag Doke added a comment -

          I tried this combination today and it was able to identify a vsphere slave node correctly:
          vsphere-cloud version 2.3
          build-flow plugin version 0.16
          Jenkins version 1.583

          Out of curiosity, I updated both plugins ... and let Jenkins stay at 1.583. That worked too. So this combination also works:
          vsphere-slave plugin 2.4
          build-flow plugin 0.17
          Jenkins version 1.583

          paragdoke Parag Doke added a comment -

          Added "core" as a component.

          paragdoke Parag Doke added a comment -

          Added "build-flow-plugin" as a component.

          danielbeck Daniel Beck added a comment -

          Would be interesting if you could narrow down the versions of Jenkins the issue originally appeared in.

          paragdoke Parag Doke added a comment -

          Works on Jenkins 1.597. Broken on 1.598 (other things being constant).

          pjdarton pjdarton added a comment -

          I've experienced similar symptoms to this when I was using a (different) broken cloud plugin - if one cloud plugin deadlocks while provisioning slaves, Jenkins can't start any slaves from any cloud plugin, as there's only one thread.

          I have, however, found that it all seems to be working fine with vSphere cloud 2.15 and Jenkins 2.32 ... but I'm not (knowingly) using the build-flow plugin.

          My guess is that this was purely an issue in the core, not with the vSphere-cloud plugin.  Parag Doke do you agree?

          paragdoke Parag Doke added a comment -

          pjdarton I am sorry I moved into another place of work ... and no longer use vsphere-slave plugin. Glad to hear it works on the plugin and Jenkins version you mentioned.

          I do not know if there were changes to the core that made this problem surface (and later fixed it) ... but in context of closing this issue, I'd be okay to close this.


            People

            • Assignee:
              Unassigned
              Reporter:
              paragdoke Parag Doke
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: