Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27383

NPE with Git Tag Message Plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: git-tag-message-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.598
      Git Tag Message Plugin 1.2
    • Similar Issues:

      Description

      Using the git tag message plugin I receive a NullPointerException:

      Checking out Revision 7f63eea9111ef89bb3c6b109a779430f9a7d800a (refs/remotes/origin/develop)
       > git config core.sparsecheckout # timeout=10
       > git checkout -f 7f63eea9111ef89bb3c6b109a779430f9a7d800a
       > git rev-list 56152421d2b22ced24473646e131d1c63414089c # timeout=10
       > git describe --tags 7f63eea9111ef89bb3c6b109a779430f9a7d800a # timeout=10
       > git tag -l -n10000 # timeout=10
      FATAL: null
      java.lang.NullPointerException
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getTagMessage(CliGitAPIImpl.java:2261)
      	at hudson.plugins.git.GitAPI.getTagMessage(GitAPI.java:108)
      	at org.jenkinsci.plugins.gittagmessage.GitTagMessageExtension.onCheckoutCompleted(GitTagMessageExtension.java:56)
      	at hudson.plugins.git.extensions.GitSCMExtension.onCheckoutCompleted(GitSCMExtension.java:161)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1047)
      	at hudson.scm.SCM.checkout(SCM.java:484)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1270)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:609)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:531)
      	at hudson.model.Run.execute(Run.java:1718)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:89)
      	at hudson.model.Executor.run(Executor.java:240)
      

      Note: There was no gti-tag-message-plugin component, so I attached this issue to the git-plugin but assigned the issue to orrc. Sorry for any grief this might cause, please re-assign without further ado.

        Attachments

          Activity

          orrc Christopher Orr added a comment -

          That looks like a pretty stupid crash. I will try to reproduce.

          Or, if you get a chance, could you please run this command on that repository and post the exact output here?
          git describe --tags 7f63eea9111ef89bb3c6b109a779430f9a7d800a

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christopher Orr
          Path:
          src/main/java/org/jenkinsci/plugins/gittagmessage/GitTagMessageExtension.java
          http://jenkins-ci.org/commit/git-tag-message-plugin/1fb0506d68030b5e1490f1becbcc5973ddfee08f
          Log:
          [FIXED JENKINS-27383] Don't attempt to fetch tag message when no tag was found.

          orrc Christopher Orr added a comment -

          Thanks for the bug report!

          Version 1.3 of the plugin has now been released, which fixes this issue.


            People

            • Assignee:
              orrc Christopher Orr
              Reporter:
              jenkey Claudio B
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: