Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27532

WorkflowTest.executorStepRestart failures

    Details

    • Similar Issues:

      Description

      Sometimes waitForCompletion times out, and the log shows that two copies of the WorkflowRun are loaded.

      Running against 1.606-SNAPSHOT, I observed an (unreproducible) failure:

      java.lang.AssertionError: tried to overwrite demo #1 with demo #1
      	at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:472)
      	at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:448)
      	at jenkins.model.lazy.AbstractLazyLoadRunMap.getByNumber(AbstractLazyLoadRunMap.java:356)
      	at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:332)
      	at jenkins.model.lazy.AbstractLazyLoadRunMap.newestBuild(AbstractLazyLoadRunMap.java:274)
      	at jenkins.model.lazy.LazyBuildMixIn.getLastBuild(LazyBuildMixIn.java:240)
      	at org.jenkinsci.plugins.workflow.job.WorkflowJob.getLastBuild(WorkflowJob.java:199)
      	at org.jenkinsci.plugins.workflow.SingleJobTestBase.rebuildContext(SingleJobTestBase.java:70)
      	at org.jenkinsci.plugins.workflow.WorkflowTest$22.evaluate(WorkflowTest.java:663)
      

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick created issue -
            jglick Jesse Glick added a comment -

            Was hoping that JENKINS-22767 was finally gone, but it seems there is some related race condition remaining.

            jglick Jesse Glick made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-22767 [ JENKINS-22767 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java
            http://jenkins-ci.org/commit/workflow-plugin/f9c921341006cfb358d474d73940209c82b8f241
            Log:
            JENKINS-27532 Noting.

            jglick Jesse Glick added a comment -

            Making WorkflowRun.onLoad sleep for a while does not suffice to reproduce, unfortunately.

            jglick Jesse Glick added a comment -

            I think this is just caused by a core bug.

            jglick Jesse Glick made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java
            http://jenkins-ci.org/commit/workflow-cps-plugin/975796059dd8aced4d96cb01ec693482d2b37115
            Log:
            JENKINS-27532 Noting.
            Originally-Committed-As: f9c921341006cfb358d474d73940209c82b8f241

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 161741 ] JNJira + In-Review [ 196855 ]
            abayer Andrew Bayer made changes -
            Component/s pipeline-general [ 21692 ]
            abayer Andrew Bayer made changes -
            Component/s workflow-plugin [ 18820 ]

              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                jglick Jesse Glick
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: