Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27713

Jenkins RobotFramework Plugin can not attach failed test case's screenshots on the report

    Details

    • Similar Issues:

      Description

      I'm trying to add failed test's screenshots on the robot report. I've found some issue on here. I added */.png on output text box. But it still didn't work. Did I miss something about that?

        Attachments

          Activity

          Hide
          patcadelina Patrick Cadelina added a comment - - edited

          My use case is that I'm using pabot to speed up `pybot` execution. When using `pabot`, screenshots are moved inside pabot's result directory

          pabot_results/<suite>.<test>/selenium-screenshot-*.png
          

          Setting `otherFiles` in `Publish Robot Framework test results` > `Advanced` to

          pabot_results/*/selenium-screenshot-*.png
          

          doesn't work.

          A workaround to is to exec

          ls pabot_results/*/selenium-screenshot-*.png | xargs cp -t .
          

          after calling `pabot`. This copies the screenshots to the workspace directory. Then setting `otherFiles` to

          selenium-screenshot-*.png
          

          Update: I just realized that the my use case is quite different. Burak Koyuncu was using

          */.png
          

          when I suppose the intended use is

          **/*.png
          

          in `otherFiles`

          Show
          patcadelina Patrick Cadelina added a comment - - edited My use case is that I'm using pabot to speed up `pybot` execution. When using `pabot`, screenshots are moved inside pabot's result directory pabot_results/<suite>.<test>/selenium-screenshot-*.png Setting `otherFiles` in `Publish Robot Framework test results` > `Advanced` to pabot_results/*/selenium-screenshot-*.png doesn't work. A workaround to is to exec ls pabot_results/*/selenium-screenshot-*.png | xargs cp -t . after calling `pabot`. This copies the screenshots to the workspace directory. Then setting `otherFiles` to selenium-screenshot-*.png Update: I just realized that the my use case is quite different. Burak Koyuncu was using */.png when I suppose the intended use is **/*.png in `otherFiles`
          Hide
          jussi_malinen Jussi Malinen added a comment -

          Hmm, documentation certainly could be improved. Does it work now for you?

          Show
          jussi_malinen Jussi Malinen added a comment - Hmm, documentation certainly could be improved. Does it work now for you?
          Hide
          patcadelina Patrick Cadelina added a comment -

          @jussi_malinen, works now. It's probably worth closing this ticket.

          OT: `pabot` resolved the issue by using a similar approach to my workaround. This shouldn't be an issue anymore since 0.15 release.

          Show
          patcadelina Patrick Cadelina added a comment - @jussi_malinen, works now. It's probably worth closing this ticket. OT: `pabot` resolved the issue by using a similar approach to my workaround. This shouldn't be an issue anymore since 0.15 release.

            People

            • Assignee:
              buurkeey Burak Koyuncu
              Reporter:
              buurkeey Burak Koyuncu
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: