Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27737

Used templates defined in folder are ignored.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
    • Environment:
      Jenkins 1.607
      CloudBees Folders Plugin 4.7
      Template Project plugin 1.4.2
    • Similar Issues:

      Description

      Used templates defined in folder are ignored.

      Observed behavior

      Given a template job: Folder/TemplateJob with builders and an actual Job: ActualJob
      When in the ActualJob configuration I choose 'Use builders from an other project' with project Folder/TemplateJob
      Then the builders from the Folder/TemplateJob are ignored

      Expected behavior

      Given a template job: Folder/TemplateJob with builders and an actual Job: ActualJob
      When in the ActualJob configuration I choose 'Use builders from an other project' with project Folder/TemplateJob
      Then the builders from the Folder/TemplateJob should be executed

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Probably unrelated to the folders plugin. The basic mechanism is in core and likely not well supported in template project plugin.

            Not critical, simply straightforward loss of functionality, i.e. Major.

            cblegare Charles Bouchard-Légaré added a comment -

            I just found a similar resolved issue Template Project plugin (JENKINS-24396). Maybe the fix is simply not available from the Plugin Manager ?

            danielbeck Daniel Beck added a comment -

            Yes, it is unreleased.

            Resolving as duplicate of JENKINS-24396.


              People

              • Assignee:
                brantone Brantone
                Reporter:
                cblegare Charles Bouchard-Légaré
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: