Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2797

Failed SCP publish attempts caused build agents to hang on next build

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Incomplete
    • Component/s: scp-plugin
    • Labels:
      None
    • Environment:
      Platform: Macintosh, OS: All
    • Similar Issues:

      Description

      We have two build agents/modes set up on our Hudson instance. When a build that is using the current
      SCP publisher plugin attempts to SFTP files and fails, it causes the next build on that agent/node to
      hang/freeze - right before it does the SVN update.

      The failed SCP publishing stack trace typically looks like:

      ERROR: Failed to upload files
      4: invalid type=0
      at com.jcraft.jsch.ChannelSftp.put(Unknown Source)
      at com.jcraft.jsch.ChannelSftp.put(Unknown Source)
      at be.certipost.hudson.plugin.SCPSite.upload(SCPSite.java:201)
      at be.certipost.hudson.plugin.SCPRepositoryPublisher.perform(SCPRepositoryPublisher.java:125)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:322)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:310)
      at hudson.model.Build$RunnerImpl.post2(Build.java:126)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:295)
      at hudson.model.Run.run(Run.java:852)
      at hudson.model.Build.run(Build.java:88)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:90)
      finished: UNSTABLE

      Disabling the SCP plugin fixed our builds from hanging.

      We're using Hudson 1.270 and SCP plugin version 1.5.2.

        Attachments

          Activity

          ramazanyich2 ramazanyich2 added a comment -

          could you send the thread dump of the slave then it hangs.
          I could not reproduce it locally on my pc.

          ramazanyich2 ramazanyich2 added a comment -

          I had once issue with hanging jobs on slave (see
          https://hudson.dev.java.net/issues/show_bug.cgi?id=462)
          Could you check that you are not in the same situation.
          Try to kill your job and check the stacktraces in log files

          evernat evernat added a comment -

          No response for 2 years


            People

            • Assignee:
              ramazanyich2 ramazanyich2
              Reporter:
              sgtcoolguy sgtcoolguy
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: