Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28078

Add support of TransientActionFactories to Workflow-plugin

    Details

    • Similar Issues:

      Description

      TransientActionFactories commonly operate with Job and Run classes, so they could be easily integrated into Workflow jobs. For example, it could be useful for HTML publisher integration.

      According to the code, TransientActions should work well in Workflow. Debigging shows that getAllActions() returns all the required data, bu links do not appear in the web interface.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            Jesse, I'll try to handle the issue if you don't mind

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Assignee Jesse Glick [ jglick ] Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev made changes -
            Environment jenkins-1.580.1
            workflow-1.5
            Issue Type Improvement [ 4 ] Bug [ 1 ]
            Description TransientActionFactories commonly operate with Job and Run classes, so they could be easily integrated into Workflow jobs. For example, it could be useful for HTML publisher integration. TransientActionFactories commonly operate with Job and Run classes, so they could be easily integrated into Workflow jobs. For example, it could be useful for HTML publisher integration.

            According to the code, TransientActions should work well in Workflow. Debigging shows that getAllActions() returns all the required data, bu links do not appear in the web interface.
            Component/s htmlpublisher-plugin [ 15681 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-26343 [ JENKINS-26343 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Bug is on my side

            oleg_nenashev Oleg Nenashev added a comment -

            Not a bug. It was my mistake

            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Not A Defect [ 7 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 162683 ] JNJira + In-Review [ 208708 ]
            abayer Andrew Bayer made changes -
            Component/s pipeline-general [ 21692 ]
            abayer Andrew Bayer made changes -
            Component/s workflow-plugin [ 18820 ]

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: