Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28186

Packer installer from packer.io just a text box

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: packer-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.596.2 (LTS), packer plugin 1.0
    • Similar Issues:

      Description

      When given the option to checkbox 'install automatically' on an older (several days since packer plugin install), there is now a way to "install from packer site" with a pulldown list of the options (i.e. Packer 0.7.5 linux-386).

      Problem: Fresh installs only get 4 options, with bare text boxes:
      extract from *.gz
      Install from packer site (just a textbox to fill in, no options)
      Run Batch
      Run Shell

      Desired outcome: a way to get the "install from packer site" to force a 'pull' or 'refresh' so there is a pulldown option to select like the other system that has been just sitting for days (versus a fresh install that is not useful).

        Attachments

          Issue Links

            Activity

            dhartford Darren Hartford added a comment -

            JENKINS_HOME/updates/biz.neustar.jenkins.plugins.paker.PackerInstaller has the JSON list of all the downloads on a sample system that works, while on the fresh system there is no file.

            bowlby Bram Enning added a comment -

            I just started using Jenkins (so using a clean install) and added the Packer plugin. I'm unable to choose a version of Packer (I get a text box).

            When I try to use a local installed version of Packer, the packer command is missing.

            [workspace] $ build /Users/me/git/my-package/packer-image.json
            FATAL: Execution failed: build /Users/me/git/my-package/packer-image.json
            Finished: FAILURE
            Build step 'Packer' marked build as failure
            Finished: FAILURE

            dhartford Darren Hartford added a comment -

            A workaround through trial and error is the following:

            1. Log into Hudson
            2. click 'manage hudson'
            3. click 'manage plugins' on the manage page
            4. select the 'Advanced' tab for plugin management
            5. In the lower right (depending on version), run 'check now' for updates. This seems to trigger all the plugins to refresh/update, which includes getting downloads for pulldowns/lists.

            Not elegant, but at least it seems to work.

            bowlby Bram Enning added a comment -

            I confirm both (the work-a-round not being elegant, but nevertheless a work-a-round)

            jdamick Jeffrey Damick added a comment -

            it appears the gradle plugin has the same issue - i'm going to investigate further for a workaround.

            jdamick Jeffrey Damick added a comment - - edited
            danielbeck Daniel Beck added a comment -

            Basically a duplicate of JENKINS-27694.


              People

              • Assignee:
                jdamick Jeffrey Damick
                Reporter:
                dhartford Darren Hartford
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: