Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28338

IO Exception: Truncated TAR archive during copy step in robot-plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: robot-plugin
    • Labels:
    • Environment:
      Jenkins 1.6.10
      Java Version 8 Update 45
      Robot Framework Plugin 1.6.0
      Windows 7
    • Similar Issues:

      Description

      Hello,
      I currently encounter the following error when using the robot framework plugin to publish our test results on jenkins.
      This error does not always appear, but in about 7 times out of 10. In the other 3 cases, the result is published correctly.
      I see this exact behavior on three different Windows 7 test machines. The generated .xml and .html files appear to be ok. Is there any possibility getting around that problem?

      Output: D:\dev\Jenkins\workspace\jst-tst\output.xml
      Log: D:\dev\Jenkins\workspace\jst-tst\log.html
      Report: D:\dev\Jenkins\workspace\jst-tst\report.html
      Robot results publisher started...
      -Parsing output xml:
      Done!
      -Copying log files to build dir:
      Failed!
      java.io.IOException: Failed to extract D:\dev\Jenkins\workspace\jst-tst/report*.html,log*.html,log*.js
      at hudson.FilePath.readFromTar(FilePath.java:2299)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:2208)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:2112)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:2095)
      at hudson.plugins.robot.RobotPublisher.copyFilesToBuildDir(RobotPublisher.java:297)
      at hudson.plugins.robot.RobotPublisher.perform(RobotPublisher.java:247)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.io.IOException: Truncated TAR archive
      at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.read(TarArchiveInputStream.java:614)
      at java.io.InputStream.read(InputStream.java:101)
      at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1792)
      at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1769)
      at org.apache.commons.io.IOUtils.copy(IOUtils.java:1744)
      at hudson.util.IOUtils.copy(IOUtils.java:40)
      at hudson.FilePath.readFromTar(FilePath.java:2289)
      ... 14 more
      Build step 'Publish Robot Framework test results' changed build result to FAILURE
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            jpiironen jpiironen added a comment -

            I think this issue comes from JENKINS-28013, which was fixed in Jenkins 1.611

            jpiironen jpiironen added a comment -

            Can you try out upgrading to 1.611 or newer and verify if this fixed your problem?

            jsturm Joachim Sturm added a comment -

            We upgraded our Jenkins to 1.6.13 and the problem seems to be gone now. Thanks alot and sorry for the bother.

            jpiironen jpiironen added a comment -

            Okay, I'm closing this as a duplicate. If the problem reappears, you can reopen this or report another issue. Thanks for the report!


              People

              • Assignee:
                jpiironen jpiironen
                Reporter:
                jsturm Joachim Sturm
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: