Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28583

Pre 2.14 gerrit-trigger.xml files cannot be loaded with 2.14+

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When a pre 2.14 gerrit-trigger.xml configuration is loaded, the gerrit-trigger plugin fails to load due to a null pointer exception.

      INFO: Starting Gerrit-Trigger Plugin
      May 26, 2015 1:10:27 PM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading plugin gerrit-trigger
      java.io.IOException: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:394)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:357)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:905)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Unable to read /home/escoheb/jenkins_home_gt/gerrit-trigger.xml
      at hudson.XmlFile.unmarshal(XmlFile.java:165)
      at hudson.Plugin.load(Plugin.java:241)
      at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.load(PluginImpl.java:494)
      at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.start(PluginImpl.java:475)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:402)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:391)
      ... 9 more
      Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
      ---- Debugging information ----
      cause-exception : java.lang.NullPointerException
      cause-message : null
      class : com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl
      required-type : com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl
      converter-type : hudson.util.RobustReflectionConverter
      path : /com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl
      line number : 169
      version : not available
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:79)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1189)
      at hudson.util.XStream2.unmarshal(XStream2.java:113)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1173)
      at hudson.XmlFile.unmarshal(XmlFile.java:163)
      ... 14 more
      Caused by: java.lang.NullPointerException
      at hudson.diagnosis.OldDataMonitor.report(OldDataMonitor.java:203)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:327)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:228)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      ... 23 more

        Attachments

          Activity

          scoheb Scott Hebert created issue -
          scoheb Scott Hebert made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Scott Hebert
          Path:
          src/main/java/com/sonyericsson/hudson/plugins/gerrit/trigger/config/Config.java
          http://jenkins-ci.org/commit/gerrit-trigger-plugin/9bb4a06c80d5bae23e284352541896687a99df21
          Log:
          Improve backwards compatibilty of Project Lister

          In moving from 2.13 to 2.14, older gerrit-trigger config files fail to load.
          This fix enables it to be backwards compatible.

          [FIXED JENKINS-28583]

          Change-Id: I0abc74e7880091d148d8d4af892d66ea90e6d8c9

          scm_issue_link SCM/JIRA link daemon made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 163429 ] JNJira + In-Review [ 197195 ]

            People

            • Assignee:
              scoheb Scott Hebert
              Reporter:
              scoheb Scott Hebert
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: