Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: mantis-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All

      Description

      Hello,

      Environment:
      Hudson 1.275
      Mantis plugin 0.5.2
      Mantis 1.2.0a3

      Since I've upgrade Mantis from 1.2.0a2 to 1.2.0a3, Mantis plugin fails to add
      notes to Mantis issues.

      Reported error is: Failed to add note to Mantis issue #1 213 (cause:
      org.xml.sax.SAXException: Invalid element in
      hudson.plugins.mantis.soap.IssueData - target_version).

      Target versions are named: "[NEXT_RELEASE]" for these issues

        Activity

        Hide
        sogabe sogabe added a comment -

        Confirmed.
        But Mantis 1.2.0a3 is still alpha version.

        Show
        sogabe sogabe added a comment - Confirmed. But Mantis 1.2.0a3 is still alpha version.
        Hide
        sfrancois99 sfrancois99 added a comment -

        Yes, but Mantis has not released a final release since 2005 Always an alpha
        or a rc, for 1.1 or 1.2 branches.

        If you don't intend to resolve it for now, I'll try to make a patch. Should I
        review Mantis SOAP code or this Hudson plugin ?

        Thanks

        Show
        sfrancois99 sfrancois99 added a comment - Yes, but Mantis has not released a final release since 2005 Always an alpha or a rc, for 1.1 or 1.2 branches. If you don't intend to resolve it for now, I'll try to make a patch. Should I review Mantis SOAP code or this Hudson plugin ? Thanks
        Hide
        sogabe sogabe added a comment -

        Hi

        >Yes, but Mantis has not released a final release since 2005 Always an alpha
        >or a rc, for 1.1 or 1.2 branches.
        Mantis 1.1.6 stable has released in December 2008.

        I'm going to fix this in around 2 or 3 tweeks. Just a minute.

        Show
        sogabe sogabe added a comment - Hi >Yes, but Mantis has not released a final release since 2005 Always an alpha >or a rc, for 1.1 or 1.2 branches. Mantis 1.1.6 stable has released in December 2008. I'm going to fix this in around 2 or 3 tweeks. Just a minute.
        Hide
        scm_issue_link SCM/JIRA link daemon added a comment -

        Code changed in hudson
        User: : sogabe
        Path:
        trunk/hudson/plugins/mantis/pom.xml
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/MantisProjectProperty.java
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/MantisSite.java
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/MantisSession.java
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/MantisSessionFactory.java
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/mantis110/MantisSessionImpl.java
        trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/mantis120/MantisSessionImpl.java
        trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global.jelly
        trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global.properties
        trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global_ja.properties
        trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/Messages.properties
        trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/Messages_ja.properties
        trunk/hudson/plugins/mantis/src/main/wsdl/mantis120.wsdl
        http://fisheye4.cenqua.com/changelog/hudson/?cs=15026
        Log:
        JENKINS-2877 Supported Mantis 1.2.0a3. You can configure the version of your mantis installation in system configuration page.

        Show
        scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sogabe Path: trunk/hudson/plugins/mantis/pom.xml trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/MantisProjectProperty.java trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/MantisSite.java trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/MantisSession.java trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/MantisSessionFactory.java trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/mantis110/MantisSessionImpl.java trunk/hudson/plugins/mantis/src/main/java/hudson/plugins/mantis/soap/mantis120/MantisSessionImpl.java trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global.jelly trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global.properties trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/MantisProjectProperty/global_ja.properties trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/Messages.properties trunk/hudson/plugins/mantis/src/main/resources/hudson/plugins/mantis/Messages_ja.properties trunk/hudson/plugins/mantis/src/main/wsdl/mantis120.wsdl http://fisheye4.cenqua.com/changelog/hudson/?cs=15026 Log: JENKINS-2877 Supported Mantis 1.2.0a3. You can configure the version of your mantis installation in system configuration page.
        Hide
        sogabe sogabe added a comment -

        Fixed in Mantis Plugin 0.6

        Show
        sogabe sogabe added a comment - Fixed in Mantis Plugin 0.6

          People

          • Assignee:
            sogabe sogabe
            Reporter:
            sfrancois99 sfrancois99
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: