Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2885

Not all jobs show-up in cc.xml report

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: github-oauth-plugin
    • Labels:
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Steps to reproduce:

      • add a new Job
      • make sure it's not run yet
      • configure CC-tray to look at: http://<your-server>/cc.xml?
      • try to add the new Job to CC-tray monitoring
        Expected result:
      • the new job can be added
        Actual result:
      • the new job does not show up in the list of 'Available projects'

      By visiting the cc.xml? URL, I could verify that the xml-file did not contain
      the new job.

      After the job has run correctly at least once, the job is addable.

        Attachments

          Issue Links

            Activity

            ssbarnea Sorin Sbarnea added a comment -

            That's true because the root cc.xml file exposes only the jobs that are present in the default view, which is not really what people would expect – I was surprised too.

            It seems that if you want all jobs you need to get /view/All/cc.xml but you will probably discover other issues, like the fact that this cc.xml requires authentications! (the root one doesnt!).

            Due to this, if you have github login integration, you will NOT be able to get cc.xml reports unless you have these jobs in the default view.

            jglick Jesse Glick added a comment -

            I have no idea what this issue refers to, but it does not sound like anything in Jenkins core.

            danielbeck Daniel Beck added a comment -

            Jesse Glick Yes, that would be great. Unfortunately…

            https://github.com/jenkinsci/jenkins/blob/master/core/src/main/resources/hudson/model/View/cc.xml.jelly

            IMO this shit should just be dropped. The file format definition doesn't even exist anymore outside of archive.org…

            ricq ricq added a comment -

            As somebody who knows the original reporter, I know that this issue has long been forgotten and there is no need to keep it open any longer. This has long been surpassed by new ways to monitor the builds, such as wall radiators with the build monitor plugin.

            Closing.

            jglick Jesse Glick added a comment -

            Daniel Beck do you volunteer to file a PR to delete cc.xml.jelly? If anyone still cares about it they can create a plugin for it.


              People

              • Assignee:
                Unassigned
                Reporter:
                gkforcare gkforcare
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: