Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28854

jenkins can't checkout https://xxxx

    Details

    • Similar Issues:

      Description

      Trying to let jenkins check out https://svn0.us-east.freebsd.org/base/stable/10 leads to:

      Kein Zugriff auf https://svn0.us-east.freebsd.org/base/stable/10 : svn: E175002: java.lang.RuntimeException: java.security.NoSuchAlgorithmException: EC AlgorithmParameters not available
      svn: E175002: OPTIONS request failed on '/base/stable/10'
      

        Attachments

          Activity

          Hide
          danielbeck Daniel Beck added a comment -

          All web search results I found on this error message indicate that this is an issue with the JRE (OpenJDK?) used, rather than related to the application.

          Show
          danielbeck Daniel Beck added a comment - All web search results I found on this error message indicate that this is an issue with the JRE (OpenJDK?) used, rather than related to the application.
          Hide
          tps800 Thomas Schweikle added a comment -

          If this would be true, why doesn't it work with

          • openjdk version "1.8.0_45"
            OpenJDK Runtime Environment (build 1.8.0_45-b13)
            OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode)

          and

          • java version "1.8.0_45"
            Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
            Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)
          Show
          tps800 Thomas Schweikle added a comment - If this would be true, why doesn't it work with openjdk version "1.8.0_45" OpenJDK Runtime Environment (build 1.8.0_45-b13) OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode) and java version "1.8.0_45" Java(TM) SE Runtime Environment (build 1.8.0_45-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)
          Hide
          tps800 Thomas Schweikle added a comment -

          The jdk-version: 8u40 seems to work without problems.

          Show
          tps800 Thomas Schweikle added a comment - The jdk-version: 8u40 seems to work without problems.
          Hide
          danielbeck Daniel Beck added a comment -

          To clarify, it is JRE dependent?

          Show
          danielbeck Daniel Beck added a comment - To clarify, it is JRE dependent?
          Hide
          tps800 Thomas Schweikle added a comment -

          Yes, it is JRE dependent. Since your post I've tried:

          • Oracle Java 1.8.0_45 -> did not work (depends on used Distribution)
          • Oracle Java 1.8.0_40 -> works
          • Oracle Java 1.7.79/80 -> works
          • OpenJDK 1.8.0_45 -> did not work
          • OpenJDK 1.7.0_79 -> did not work

          I've tried to install the cryptographic extensions to overcome the problem with OpenJDK, but without success.
          For Oracle Java 1.8.0_45 I could verify it working on Orcale Linux, CentOS, RedHat Enterprise (all 6.6, 7.1), but not on Ubuntu (14.04 LTS) or Debian – looks like there is some sort of library incompatibility or some library not available with the right version number.

          As of now I got it working.

          Show
          tps800 Thomas Schweikle added a comment - Yes, it is JRE dependent. Since your post I've tried: Oracle Java 1.8.0_45 -> did not work (depends on used Distribution) Oracle Java 1.8.0_40 -> works Oracle Java 1.7.79/80 -> works OpenJDK 1.8.0_45 -> did not work OpenJDK 1.7.0_79 -> did not work I've tried to install the cryptographic extensions to overcome the problem with OpenJDK, but without success. For Oracle Java 1.8.0_45 I could verify it working on Orcale Linux, CentOS, RedHat Enterprise (all 6.6, 7.1), but not on Ubuntu (14.04 LTS) or Debian – looks like there is some sort of library incompatibility or some library not available with the right version number. As of now I got it working.

            People

            • Assignee:
              Unassigned
              Reporter:
              tps800 Thomas Schweikle
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: