Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2890

very low performance when starting the server

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      It takes almost an hour to start the hudson server.

      Maybe, the scanning of the entire data of existing jobs could be split up
      into an initial reading of the absolutely necessary information for displaying
      the user interface and a deferred scan of the entire data available with each
      job (for trend graphs etc.)?

      (Environment: hudson 1.276, jboss, linux, approx. 600 jobs)

        Attachments

          Issue Links

            Activity

            kherm kherm added a comment -

            This performance issue has a high priority in our environment.

            kohsuke Kohsuke Kawaguchi added a comment -

            discarding the unnecessary builds help.

            This is more of a longer term work that cannot be quickly done.

            mdonohue mdonohue added a comment -

            Dup

                • This issue has been marked as a duplicate of 2487 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                kherm kherm
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: