Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29058

Unparseable date exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: docker-workflow-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.617
      Workflow Plugins 1.8
      Docker 1.7.0
      CentOS 7.0
      Java 1.7
      OpenJDK rhel-2.5.5.2.el7_1-x86_64
    • Similar Issues:

      Description

      I'm trying to run the following workflow script:

      node {
          // https://registry.hub.docker.com/_/maven/
          def maven32 = docker.image('maven:3.2-jdk-7-onbuild');
          
          stage 'Mirror'
          // First make sure the slave has this image.
          // (If you could set your registry below to mirror Docker Hub,
          // this would be unnecessary as maven32.inside would pull the image.)
          maven32.pull()
          // We are pushing to a private secure docker registry in this demo.
          // 'docker-registry-login' is the username/password credentials ID
          // as defined in Jenkins Credentials.
          // This is used to authenticate the docker client to the registry.
      
          maven32.withRun() {
              stage 'Build'
      
              git url: 'ssh://git@github.com/me/myrepo.git', credentialsId: 'myid'
          }
      }
      

      I got the template for the script from here (https://gist.github.com/jglick/0aa389c053196e38e2a1).

      While running it, Jenkins runs into the following problem:

      Started by user anonymous
      Running: Allocate node : Start
      Running on master in /var/lib/jenkins/jobs/Workflow Test/workspace
      Running: Allocate node : Body : Start
      Running: Mirror
      Entering stage Mirror
      Proceeding
      Running: Shell Script
      [workspace] Running shell script
      + docker pull maven:3.2-jdk-7-onbuild
      Pulling repository maven
      6e40c3d05989: Pulling image (3.2-jdk-7-onbuild) from maven
      6e40c3d05989: Pulling image (3.2-jdk-7-onbuild) from maven, endpoint: https://registry-1.docker.io/v1/
      6e40c3d05989: Pulling dependent layers
      511136ea3c5a: Download complete
      3b3a4796eef1: Download complete
      50ec2d202fe8: Download complete
      1073b544a1cb: Download complete
      6a7520a7fd8c: Download complete
      060a97546ea3: Download complete
      4d752356e7c6: Download complete
      0b2411d869ec: Download complete
      fa5c5774f090: Download complete
      454ad080ec94: Download complete
      0126b2343320: Download complete
      3914c9d781f8: Download complete
      4806e724fbc6: Download complete
      45ebf0d25a39: Download complete
      4d85b28153e8: Download complete
      20df44085bd4: Download complete
      6e40c3d05989: Download complete
      6e40c3d05989: Download complete
      Status: Image is up to date for maven:3.2-jdk-7-onbuild
      Running: Shell Script
      [workspace] Running shell script
      + docker run -d maven:3.2-jdk-7-onbuild
      Running: Read file from workspace
      Running: Record trace of a Docker image run in a container
      Running: Allocate node : Body : End
      Running: Allocate node : End
      Running: End of Workflow
      java.io.IOException: Error parsing created date '2015-06-24 12:20:56.680848453 +0000 UTC' for object 'a13617f6773c74ee73fe75138fbd2a35c7e4597fd7bcec1c0a7fb39119eb1804'.
      	at org.jenkinsci.plugins.docker.workflow.client.DockerClient.getCreatedDate(DockerClient.java:169)
      	at org.jenkinsci.plugins.docker.workflow.client.DockerClient.getContainerRecord(DockerClient.java:263)
      	at org.jenkinsci.plugins.docker.workflow.RunFingerprintStep$Execution.run(RunFingerprintStep.java:75)
      	at org.jenkinsci.plugins.docker.workflow.RunFingerprintStep$Execution.run(RunFingerprintStep.java:63)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousStepExecution.start(AbstractSynchronousStepExecution.java:34)
      	at org.jenkinsci.plugins.workflow.cps.DSL.invokeMethod(DSL.java:136)
      	at org.jenkinsci.plugins.workflow.cps.CpsScript.invokeMethod(CpsScript.java:98)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:45)
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:42)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:108)
      	at com.cloudbees.groovy.cps.sandbox.DefaultInvoker.methodCall(DefaultInvoker.java:15)
      	at org.jenkinsci.plugins.docker.workflow.Docker$Image.run(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:128)
      	at org.jenkinsci.plugins.docker.workflow.Docker.node(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:63)
      	at org.jenkinsci.plugins.docker.workflow.Docker$Image.run(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:125)
      	at org.jenkinsci.plugins.docker.workflow.Docker$Image.withRun(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:135)
      	at org.jenkinsci.plugins.docker.workflow.Docker.node(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:63)
      	at org.jenkinsci.plugins.docker.workflow.Docker$Image.withRun(jar:file:/var/lib/jenkins/plugins/docker-workflow/WEB-INF/lib/docker-workflow.jar!/org/jenkinsci/plugins/docker/workflow/Docker.groovy:134)
      	at WorkflowScript.run(WorkflowScript:15)
      	at Unknown.Unknown(Unknown)
      	at ___cps.transform___(Native Method)
      	at com.cloudbees.groovy.cps.impl.ContinuationGroup.methodCall(ContinuationGroup.java:69)
      	at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.dispatchOrArg(FunctionCallBlock.java:106)
      	at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.fixArg(FunctionCallBlock.java:79)
      	at sun.reflect.GeneratedMethodAccessor524.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      	at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.dispatch(CollectionLiteralBlock.java:55)
      	at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.item(CollectionLiteralBlock.java:45)
      	at sun.reflect.GeneratedMethodAccessor568.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      	at com.cloudbees.groovy.cps.impl.PropertyishBlock$ContinuationImpl.get(PropertyishBlock.java:64)
      	at com.cloudbees.groovy.cps.LValueBlock$GetAdapter.receive(LValueBlock.java:30)
      	at com.cloudbees.groovy.cps.impl.PropertyishBlock$ContinuationImpl.fixName(PropertyishBlock.java:54)
      	at sun.reflect.GeneratedMethodAccessor527.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      	at com.cloudbees.groovy.cps.impl.ConstantBlock.eval(ConstantBlock.java:21)
      	at com.cloudbees.groovy.cps.Next.step(Next.java:58)
      	at com.cloudbees.groovy.cps.Continuable.run0(Continuable.java:145)
      	at org.jenkinsci.plugins.workflow.cps.CpsThread.runNextChunk(CpsThread.java:164)
      	at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup.run(CpsThreadGroup.java:271)
      	at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup.access$000(CpsThreadGroup.java:71)
      	at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$2.call(CpsThreadGroup.java:180)
      	at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$2.call(CpsThreadGroup.java:178)
      	at org.jenkinsci.plugins.workflow.cps.CpsVmExecutorService$2.call(CpsVmExecutorService.java:47)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:112)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.text.ParseException: Unparseable date: "2015-06-24 12:20:56"
      	at java.text.DateFormat.parse(DateFormat.java:357)
      	at org.jenkinsci.plugins.docker.workflow.client.DockerClient.getCreatedDate(DockerClient.java:167)
      	at org.jenkinsci.plugins.docker.workflow.client.DockerClient.getContainerRecord(DockerClient.java:263)
      	at org.jenkinsci.plugins.docker.workflow.RunFingerprintStep$Execution.run(RunFingerprintStep.java:75)
      	at org.jenkinsci.plugins.docker.workflow.RunFingerprintStep$Execution.run(RunFingerprintStep.java:63)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousStepExecution.start(AbstractSynchronousStepExecution.java:34)
      	at org.jenkinsci.plugins.workflow.cps.DSL.invokeMethod(DSL.java:136)
      	at org.jenkinsci.plugins.workflow.cps.CpsScript.invokeMethod(CpsScript.java:98)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:45)
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:42)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:108)
      	at com.cloudbees.groovy.cps.sandbox.DefaultInvoker.methodCall(DefaultInvoker.java:15)
      	... 37 more
      Finished: FAILURE
      

      I hope someone can help me out with this error since I think this is a bug.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Was already fixed in https://github.com/jenkinsci/docker-workflow-plugin/pull/16 though it seems this is unreleased.


              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                kummerer94 Alexander Kammerer
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: