Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2909

Endless authentication to SVN when invalid user/password

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I found this in hudson 235 and it is still in hudson 277.

      How to recreate it:

      • Create project with SVN Repository (http protocol and user/name
        authentication)
      • Tick Poll SCM for emaple to '* * * * *'
      • After a few minutes change the password of the SVN user you used in
        authentication (Do it in your SVN environment, NOT in hudson - hudson will not
        know anything about password 'expiration')
        Observed results:
        Polling will start endless authentication tries... (about 5-10 requests per
        sec.)
        Expected results:
        After one or two attempts poll should stop trying to authenticate

      The problem is in method
      SubversionSCM.SVNAuthenticationProviderImpl.requestClientAuthentication(...) {
      }
      It always returns credentials (invalid), however, it should return it only once
      (at the first attempt to authentication). Other words should be aware of input
      parameters: SVNErrorMessage errorMessage, SVNAuthentication previousAuth

      Witold Delekta

        Attachments

          Issue Links

            Activity

            dodok1 dodok1 added a comment -
                • Issue 3885 has been marked as a duplicate of this issue. ***
            dty Dean Yu added a comment -

            Adding to cc

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/subversion/src/main/java/hudson/scm/SubversionSCM.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=19188
            Log:
            [FIXED JENKINS-2909] Endless authentication to SVN when invalid user/password. I shall put this in 1.313.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=19206
            Log:
            recording JENKINS-2909 for 1.313

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/war/pom.xml
            http://fisheye4.cenqua.com/changelog/hudson/?cs=19207
            Log:
            recording JENKINS-2909 for 1.313


              People

              • Assignee:
                Unassigned
                Reporter:
                witolddelekta witolddelekta
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: