Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29178

Robot Framework 2.9 output parsing is broken

    Details

    • Similar Issues:

      Description

      Robot 2.9 no longer includes empty elements in the output xml. If a test does not have any tags, this breaks the output parsing from the plugin.

        Attachments

          Activity

          jussi_malinen Jussi Malinen created issue -
          jussi_malinen Jussi Malinen made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          jussi_malinen Jussi Malinen made changes -
          Description Robot 2.9 no longer includes empty elements in the output xml. If a test does not have any tags, this breaks the output parsing from the plugin. Robot 2.9 [no longer includes empty elements in the output xml|https://github.com/robotframework/robotframework/issues/2020]. If a test does not have any tags, this breaks the output parsing from the plugin.
          jussi_malinen Jussi Malinen made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 164046 ] JNJira + In-Review [ 197396 ]
          aleksisimell Aleksi Simell made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          vikashks vikash srivastava added a comment - - edited

          i still see this issue with RF 3.1.2 and jenkins robot plugin 1.6.5 , any reason to close the ticket?

          11:18:53 Failed! 11:18:53 java.io.IOException: Parsing of output xml failed! 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.setRobotResult(RobotParser.java:151) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.invoke(RobotParser.java:82) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.invoke(RobotParser.java:58) 11:18:53 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052) 11:18:53 at hudson.remoting.UserRequest.perform(UserRequest.java:212) 11:18:53 at hudson.remoting.UserRequest.perform(UserRequest.java:54) 11:18:53 at hudson.remoting.Request$2.run(Request.java:369) 11:18:53 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) 11:18:53 at java.util.concurrent.FutureTask.run(FutureTask.java:266) 11:18:53 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) 11:18:53 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) 11:18:53 at java.lang.Thread.run(Thread.java:748) 11:18:53 Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to 10.133.166.10 - Finland-Cloud1 11:18:53 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1743) 11:18:53 at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:357) 11:18:53 at hudson.remoting.Channel.call(Channel.java:957) 11:18:53 at hudson.FilePath.act(FilePath.java:1072) 11:18:53 at hudson.FilePath.act(FilePath.java:1061) 11:18:53 at hudson.plugins.robot.RobotParser.parse(RobotParser.java:53) 11:18:53 at hudson.plugins.robot.RobotPublisher.parse(RobotPublisher.java:223) 11:18:53 at hudson.plugins.robot.RobotPublisher.perform(RobotPublisher.java:247) 11:18:53 at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:80) 11:18:53 at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:67) 11:18:53 at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution.lambda$start$0(SynchronousNonBlockingStepExecution.java:47) 11:18:53 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) 11:18:53 at java.util.concurrent.FutureTask.run(FutureTask.java:266) 11:18:53 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) 11:18:53 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) 11:18:53 at java.lang.Thread.run(Thread.java:745) 11:18:53 Caused by: javax.xml.stream.XMLStreamException: Could not find elements [doc] (at line: 110165 column: 1) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.xmlException(RobotParser.java:254) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.ignoreUntilStarts(RobotParser.java:292) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processTest(RobotParser.java:351) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:213) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:211) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.parseResult(RobotParser.java:169) 11:18:53 at hudson.plugins.robot.RobotParser$RobotParserCallable.setRobotResult(RobotParser.java:145) 11:18:53 ... 11 more


            People

            • Assignee:
              jussi_malinen Jussi Malinen
              Reporter:
              jussi_malinen Jussi Malinen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: