Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29262

ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com java.lang.NullPointerException

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: artifactory-plugin
    • Labels:
    • Environment:
      Jenkins ( Version 1.596.2 )
      Artifactory Plugin ( Version 2.2.4 )
      Java 1.6, Linux , Tomcat deployment
    • Similar Issues:

      Description

      CI build are working fine on the same environment, however when I am trying to create Release Build using artifactory release staging option, its giving below error:

      build
      [RELEASE] Release build triggered
      [RELEASE] Changing POMs to release version
      Parsing POMs
      Failed to transfer Could not find artifact com.ondot:ondotProvisioningConnector:pom:3.0.1.3 in central (<artifactoryserverURL>/artifactory/libs-release)
      Failed to transfer Could not find artifact com.ondot:ondotProvisioningConnector:pom:3.0.1.3 in snapshots (<artifactoryserverURL>/artifactory/libs-snapshot)
      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      java.lang.NullPointerException
      at org.jfrog.hudson.release.maven.MavenReleaseWrapper$2.tearDown(MavenReleaseWrapper.java:170)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:878)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)

      I ensured all the JAVA_HOME & MAVEN_HOME variables are appropriate, what could be the cause of this problem.

      Any help would be appreciated, Thanks in advance!!

        Attachments

          Activity

          jenkinsswapnil swapnil soor added a comment -

          Any update please

          jenkinsswapnil swapnil soor added a comment -

          Any help regarding this would be appreciated, again I am facing the exactly same error for one of the Job while trying for release build, same CI job was working absolutely fine till now, & surprisingly other Jobs CI as well as Release builds working fine, so I'm wondering what could make it fail all of sudden.

          jenkinsswapnil swapnil soor added a comment -

          Please update any info on this.

          jenkinsswapnil swapnil soor added a comment -

          Oh, It was some internal parent dependency issue, got the fix, but error was misleading. Normally it should point the pom error, which was the case.

          Anyways, it got fixed now, Thanks!

          jenkinsswapnil swapnil soor added a comment -

          It was pom.xml file issue only, incorrect parent dependency. Since it was working fine during CI build could not out the cause immediately & thought its plugin issue.


            People

            • Assignee:
              jenkinsswapnil swapnil soor
              Reporter:
              jenkinsswapnil swapnil soor
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: