Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29340

E200015: ISVNAuthentication provider did not provide credentials

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      * Jenkins version 1.613
      * Subversion Plugin version 2.5.1
      * Env Inject Plugin version 1.91.3
    • Similar Issues:

      Description

      Steps to reproduce the bug

      • Configure Job enabling Prepare environment for the run
      • Create a variable REPOSITORIO
      • Define svn url using created variable REPOSITORIO
      • Add credentials
      • Configure check scm every minute (testing purposes)

      Error

      scmPollLog error:

      Started on 10-jul-2015 11:19:00
      Received SCM poll call on master for OXM_IC on 10-jul-2015 11:19:00
      ERROR: Error al obtener la revisión http://subversion-dsa.gva.es/svn/oxm/trunk del repositorio
      org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:60)
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:759)
      	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:371)
      	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:359)
      	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:710)
      	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:627)
      	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:102)
      	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1032)
      	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:175)
      	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
      	at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
      	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
      	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteGetInfo.run(SvnRemoteGetInfo.java:46)
      	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteGetInfo.run(SvnRemoteGetInfo.java:31)
      	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      	at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2523)
      	at hudson.scm.SubversionSCM.parseSvnInfo(SubversionSCM.java:1223)
      	at hudson.scm.CompareAgainstBaselineCallable.call(CompareAgainstBaselineCallable.java:78)
      	at hudson.scm.CompareAgainstBaselineCallable.call(CompareAgainstBaselineCallable.java:26)
      	at hudson.remoting.LocalChannel.call(LocalChannel.java:45)
      	at hudson.scm.SubversionSCM.compareRemoteRevisionWith(SubversionSCM.java:1408)
      	at hudson.scm.SCM.compareRemoteRevisionWith(SCM.java:381)
      	at hudson.scm.SCM.poll(SCM.java:398)
      	at hudson.model.AbstractProject._poll(AbstractProject.java:1453)
      	at hudson.model.AbstractProject.poll(AbstractProject.java:1356)
      	at jenkins.triggers.SCMTriggerItem$SCMTriggerItems$Bridge.poll(SCMTriggerItem.java:119)
      	at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:510)
      	at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:539)
      	at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:689)
      	... 34 more
      Done. Took 0,13 Seg
      No changes
      

        Attachments

          Issue Links

            Activity

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, Could you attach a screenshot with your repository configuration?

            ricardogarfe Ricardo García Fernández added a comment - - edited

            Repository configuration using credentials, also defined properties for the run as repository url name.

            Error 405 in configuration is not important

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, Could you try without URL parameters?

            ricardogarfe Ricardo García Fernández added a comment -

            It works without URL parameters (without using REPOSITORIO variable)

            danielbeck Daniel Beck added a comment -
            recena Manuel Recena Soto added a comment -

            Daniel Beck Thanks for the advice. Is there any reason why that PR has not been merged?

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, I'm trying to reproduce the bug.

            recena Manuel Recena Soto added a comment - - edited

            Ricardo García Fernández I could not reproduce it.

            I used the same environment: Jenkins 1.613, Subversion Plugin (2.5.1) and EnvInject Plugin 1.91.3 and I followed the steps described above. The result:

            Lanzada por el usuario anonymous
            [EnvInject] - Loading node environment variables.
            [EnvInject] - Preparing an environment for the build.
            [EnvInject] - Keeping Jenkins system variables.
            [EnvInject] - Keeping Jenkins build variables.
            [EnvInject] - Injecting as environment variables the properties content REPO=jenkins-26318
            [EnvInject] - Variables injected successfully.
            [EnvInject] - Injecting contributions.
            Ejecutando.en el espacio de trabajo /Users/recena/Documents/workspace-luna-cb/subversion-plugin/work/workspace/JENKINS-29308
            Checking out a fresh workspace because there's no workspace at /Users/recena/Documents/workspace-luna-cb/subversion-plugin/work/workspace/JENKINS-29308
            Cleaning local Directory .
            Checking out https://subversion.assembla.com/svn/jenkins-26318/trunk at revision '2015-07-12T12:55:34.653 +0200'
            A         src
            A         src/test
            A         src/test/java
            A         src/test/java/com
            A         src/test/java/com/cloudbees
            A         src/test/java/com/cloudbees/manticore
            A         src/test/java/com/cloudbees/manticore/AppTest.java
            A         src/main
            A         src/main/java
            A         src/main/java/com
            A         src/main/java/com/cloudbees
            A         src/main/java/com/cloudbees/manticore
            A         src/main/java/com/cloudbees/manticore/App.java
            A         pom.xml
            A         logparser-rules.txt
            At revision 12
            Finished: SUCCESS
            

            I think it would be interesting to improve the repository validation and avoid this message: JENKINS-29308.png

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, I've also tried using a slave node. Everything works fine.

            recena Manuel Recena Soto added a comment - - edited

            Ricardo García Fernández, I've recorded a screencast showing the process: https://goo.gl/Xi8Q6f

            So that I can go ahead with this bug, I need more detailed information.

            ricardogarfe Ricardo García Fernández added a comment -

            Manuel Recena Soto thanks for the screencast, but the problem appears when the jobs tries to check if there's any update in the scm repository 'via' scmPollLog:

            Here if you use an environment variable into scm url this section fails and you can't check if there are any updates in repository. Thanks!

            ricardogarfe Ricardo García Fernández added a comment -

            Screencast

            I've recorded another screencast with the error:

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, I've reproduced the bug. Thanks so much.

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, I assume that this functionality was working in prior versions, Isn't that so?

            ricardogarfe Ricardo García Fernández added a comment -

            Manuel Recena Soto, yes because of that we realise of this bug after updating svn 2.4.5 to svn 2.5 (2.5.1)

            danielbeck Daniel Beck added a comment -

            Manuel Recena Soto

            Thanks for the advice. Is there any reason why that PR has not been merged?

            At the time I was sick of other contributors (Stephen and Steven) ignoring open, recent, PRs before merging large-scale changes that made those PRs unmergeable. After the second or third time I just stopped caring and used my own custom build. And since then the PR no longer can be merged cleanly.

            recena Manuel Recena Soto added a comment - - edited

            Ricardo García Fernández, a PR has been sent.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: recena
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            http://jenkins-ci.org/commit/subversion-plugin/5017b4b153beabb1a82181458dbd4cfedb4fd1d7
            Log:
            JENKINS-29340 E200015: ISVNAuthentication provider did not provide credentials

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: recena
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            http://jenkins-ci.org/commit/subversion-plugin/72c376614e9bf60ee02926855edf8470a03779f5
            Log:
            JENKINS-29340 ISVNAuthentication provider did not provide credentials

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Recena
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            http://jenkins-ci.org/commit/subversion-plugin/91516c4adbefbf9c67d477a2d4f15ca26d63f588
            Log:
            Merge pull request #127 from recena/JENKINS-29340

            JENKINS-29340 ISVNAuthentication provider did not provide credentials

            Compare: https://github.com/jenkinsci/subversion-plugin/compare/d951dc137eb9...91516c4adbef

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, the PR has been merged. It would be very interesing if you try this HPI in a development environment.

            ricardogarfe Ricardo García Fernández added a comment -

            Hi Manuel Recena Soto, HPI works ok with SVN Polling.

            ricardogarfe Ricardo García Fernández added a comment -

            thanks for the code !

            ricardogarfe Ricardo García Fernández added a comment -

            thanks for the code !

            recena Manuel Recena Soto added a comment - - edited

            Ricardo García Fernández, thanks so much for your feedback.

            I didn't like the current solution and I was working on an alternative. We want to cut a release at the end of this week.

            ricardogarfe Ricardo García Fernández added a comment -

            Thanks again Manuel Recena Soto, I'll be impatient during the week .
            I've took a look at PR code.

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández This bug involves to modify EnvInject Plugin. I've filled this ticket JENKINS-29817 and I send a PR.

            ricardogarfe Ricardo García Fernández added a comment -

            Manuel Recena Soto thanks for the tip. I'm watching JENKINS-29817 issue any dates about releases (envinject and subversion) roadmap ?
            thanks a lot !

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, I don't know. It is impossible to estimate because my PRs depend on maintainer's reviews. Here you can find an example.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: recena
            Path:
            pom.xml
            src/main/java/hudson/scm/SubversionSCM.java
            src/main/java/hudson/scm/subversion/WorkspaceUpdater.java
            src/test/java/hudson/scm/SubversionEnvInjectTest.java
            src/test/java/hudson/scm/SubversionSCMTest.java
            http://jenkins-ci.org/commit/subversion-plugin/bdab3bab552c2d6d7785ab4d2eb122dcc1de9094
            Log:
            JENKINS-29340 Implemented a new proposal

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Recena
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/f448c8d2205e0c704db8401346381f8d1735c65f
            Log:
            JENKINS-29340 Updated EnvInject dependency (test scope)

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: recena
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/51cd6d318f4211c2a488a62e7a5dc6b6b197159c
            Log:
            JENKINS-29340 Updated EnvInject dependency to latest release

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: recena
            Path:
            src/main/java/hudson/scm/subversion/WorkspaceUpdater.java
            src/test/java/hudson/scm/SubversionSCMTest.java
            http://jenkins-ci.org/commit/subversion-plugin/21bde20c195204dd5be3de7b88194968faed308e
            Log:
            JENKINS-29340 Removed unrelated changes

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Recena
            Path:
            src/test/java/hudson/scm/SubversionEnvInjectTest.java
            http://jenkins-ci.org/commit/subversion-plugin/d89f5305989833e6a9a12666589d5996fd5938f0
            Log:
            JENKINS-29340 Some comments have been added to pollingWithEnvInject test

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Recena
            Path:
            pom.xml
            src/main/java/hudson/scm/SubversionSCM.java
            src/test/java/hudson/scm/SubversionEnvInjectTest.java
            http://jenkins-ci.org/commit/subversion-plugin/b029f4086567971b1f9fa736d6d10679c27650a3
            Log:
            Merge pull request #131 from recena/JENKINS-29340

            JENKINS-29340 ISVNAuthentication provider did not provide credentials (part. II)

            Compare: https://github.com/jenkinsci/subversion-plugin/compare/2e95528de59c...b029f4086567

            recena Manuel Recena Soto added a comment -

            This solved bug will be included on Subversion Plugin 2.5.2

            recena Manuel Recena Soto added a comment -

            Ricardo García Fernández, you will have to update both Subversion Plugin (to 2.5.2) and EnvInject Plugin (1.92).

            ricardogarfe Ricardo García Fernández added a comment -

            Updated and working in both environments

            esheffield Evan Sheffield added a comment -

            It looks like this is resolved when using the "Properties Content" section of Prepare environment for the run, but the exception is still occurring if the same environment variable is injected instead using "Evaluated Groovy Script".

            For example, using this groovy script will cause the same exception described initially:

            def map = [REPOSITORIO: "/my/repo/path"]
            return map
            
            recena Manuel Recena Soto added a comment -

            Evan Sheffield, Please, read the help information.

            Properties Content

            These environment variables (only these) will be available in the Job environment independently from the build. There are following use-cases: SCM polling, validation of fields depending on environment variables (e.g. http://server/svn/$REPO), custom workspace management, etc.

            esheffield Evan Sheffield added a comment -

            Manuel Recena Soto Ah, apologies, I didn't notice this caveat. Thank you for pointing that out. Do you know if there are any workarounds that would allow me to load that environment variable dynamically? The value I'm depending on is generated by running another job, so it doesn't seem like I would be able to load it using "Properties Content".

            recena Manuel Recena Soto added a comment -

            Evan Sheffield, I think it is better if you use jenkinsci-user mailing list to share your request. In my opinion, EnvInject is not designed for that.

            ralf_muehle Ralf Mühle added a comment - - edited

            After JENKINS-29352 is marked as duplicate of this bug:
            With Jenkins 1.629 and SVN Plugin 2.5.3 the bug is not resolved.

            Location 'https://xxxx/${SVN_TRUNK}' does not exist
            One or more repository locations do not exist anymore for hudson.maven.MavenModuleSet@a8864af[TEST_MVN_JOB], project will be disabled.
            The project has been disabled

            SVN_TRUNK is a global environment variable defined in Mange Jenkins - Configure System - Global Properties - Env. Variables

            I get this error with a maven project and freestyle project

            recena Manuel Recena Soto added a comment -

            Ralf Mühle

            Please, file a new JIRA ticket including a step by step process to reproduce the bug.

            The bug described in this ticket was resolved and confirmed by users.


              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                ricardogarfe Ricardo García Fernández
              • Votes:
                1 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: