Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29571

Unreadable data after renaming a Workflow job

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: pipeline
    • Labels:
      None
    • Similar Issues:

      Description

      Steps to reproduce it:

      1. Create a WF job with some dummy script
      2. Run a build (or two)
      3. Rename the job
      4. Restart Jenkins
      5. You have unreadable data warnings in "Manage Jenkins"

      The root cause is in build.xml files, where the job name is not properly changed in the rename process:

      ...
      <owner class="flow-owner">
          <job>test2</job>
          <id>2015-07-22_13-25-38</id>
      </owner>
      ...
      

      Behavior checked using Jenkins 1.580.2 + Workflow 1.4 and 1.609.1 + Workflow 1.8

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            api/src/main/java/org/jenkinsci/plugins/workflow/flow/FlowExecution.java
            http://jenkins-ci.org/commit/workflow-api-plugin/e26d0b7daa2cccae76ca7494e8fe35a8b31604dd
            Log:
            [FIXED JENKINS-29571] Make CpsFlowExecution.owner transient (JENKINS-27704) to avoid problems after renames/moves.
            Originally-Committed-As: b7014e66b8b064794efea6c78f35160c5250cc2e

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            cps/src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlowExecution.java
            cps/src/test/java/org/jenkinsci/plugins/workflow/cps/CpsFlowDefinition2Test.java
            http://jenkins-ci.org/commit/workflow-cps-plugin/e4d1b6291b92f6c82f6cbd652b5c62067aeb7119
            Log:
            [FIXED JENKINS-29571] Make CpsFlowExecution.owner transient (JENKINS-27704) to avoid problems after renames/moves.
            Originally-Committed-As: b7014e66b8b064794efea6c78f35160c5250cc2e

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowRunTest.java
            http://jenkins-ci.org/commit/workflow-job-plugin/305082c4530f6253878a8a3700d4881e8da6627d
            Log:
            JENKINS-29571 reproduced in test and confirmed to depend on part of JENKINS-27704.
            Originally-Committed-As: 9d087ca7fcb3e6f186d3f44f289bae8861dedad7

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowRunTest.java
            job/src/main/java/org/jenkinsci/plugins/workflow/job/WorkflowRun.java
            http://jenkins-ci.org/commit/workflow-job-plugin/5170bb152334a56987f03711ef3896d64fb98bc0
            Log:
            [FIXED JENKINS-29571] Make CpsFlowExecution.owner transient (JENKINS-27704) to avoid problems after renames/moves.
            Originally-Committed-As: b7014e66b8b064794efea6c78f35160c5250cc2e

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            job/src/main/java/org/jenkinsci/plugins/workflow/job/WorkflowRun.java
            http://jenkins-ci.org/commit/workflow-job-plugin/c034f77059966d1097e16a2bcc1dad2ddbe41994
            Log:
            The fix of JENKINS-27531 in #97 seems to be made simpler by the fix of JENKINS-29571 via JENKINS-27704 in #157.
            We only needed getId(WorkflowRun) because CpsFlowExecution.unmarshal was trying to use an Owner.
            Originally-Committed-As: fc3851f4df8881e24c079cf51f42b48ec9596ab9


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                amuniz Antonio Muñiz
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: