Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29583

Unable to update to Jenkins 1.621

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Win Server
    • Similar Issues:

      Description

      In Jenkins I get a message that a new version 1.621 is available but when I try to update I get an error. Seems that after the redirect, there is no war file there...

      jenkins.war
      Failure -
      hudson.util.IOException2: Failed to download from http://updates.jenkins-ci.org/download/war/1.621/jenkins.war (redirected to: http://archives.jenkins-ci.org/war/1.621/jenkins.war)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:797)
      at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1148)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1126)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.FileNotFoundException: http://archives.jenkins-ci.org/war/1.621/jenkins.war
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:757)
      ... 6 more
      Caused by: java.io.FileNotFoundException: http://archives.jenkins-ci.org/war/1.621/jenkins.war
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(Unknown Source)
      at java.net.URLConnection.getHeaderFieldLong(Unknown Source)
      at java.net.URLConnection.getContentLengthLong(Unknown Source)
      at java.net.URLConnection.getContentLength(Unknown Source)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:756)
      ... 6 more

        Attachments

          Activity

          vassilena Vassilena Treneva created issue -
          mwebber Matthew Webber added a comment -
          mwebber Matthew Webber made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 164463 ] JNJira + In-Review [ 209043 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              vassilena Vassilena Treneva
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: