Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29595

Build-flow project not sending mail notification

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: build-flow-plugin
    • Labels:
      None
    • Environment:
      Jenkins version - 1.619
      Build-Flow plugin version - 0.18
      Email-Extension plugin version - 2.40.5

      Jenkins is running on MAC
    • Similar Issues:

      Description

      This is first project I'm working on Build-flow project.
      I have configured Editable Email Notification in Post-build Action.

      But after build is completed the email is not triggered for any condition (success or failure).

        Attachments

          Activity

          Hide
          slide_o_mix Alex Earl added a comment -

          Need lots more information. This works for me in my setup at work. Need the config.xml for the job and the global xml for email-ext from JENKINS_HOME

          Show
          slide_o_mix Alex Earl added a comment - Need lots more information. This works for me in my setup at work. Need the config.xml for the job and the global xml for email-ext from JENKINS_HOME
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          I was able to find only config.xml for the job. Same attached.
          Unable to find global.xml for email-extn plugin.

          Good day.
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, I was able to find only config.xml for the job. Same attached. Unable to find global.xml for email-extn plugin. Good day. Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          Can you also provide a build log?

          Show
          slide_o_mix Alex Earl added a comment - Can you also provide a build log?
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          Below is the build log content.

          Started by user anonymous
          RHODESVERSION 5.0
          Finished: SUCCESS

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, Below is the build log content. Started by user anonymous RHODESVERSION 5.0 Finished: SUCCESS Regards, Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          Can you enable debug mode in the global config for email-ext and run again?

          Show
          slide_o_mix Alex Earl added a comment - Can you enable debug mode in the global config for email-ext and run again?
          Hide
          manojoshi Manoj Kumar added a comment -

          No change in build log after enabling debug mode.
          It's same
          Started by user anonymous
          RHODESVERSION 5.0
          Finished: SUCCESS

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - No change in build log after enabling debug mode. It's same Started by user anonymous RHODESVERSION 5.0 Finished: SUCCESS Regards, Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          Then it looks like the email-ext plugin is not being called.

          Show
          slide_o_mix Alex Earl added a comment - Then it looks like the email-ext plugin is not being called.
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          I don't know what does it mean email-ext plugin is not being called.
          I'm sure you might have gone through the project config.xml i have attached earlier.
          and it is clearly shows email-ext plugin is configured with equird fiels.

          If you still feel I have missed something in configuration please let me know.
          Appreciated if you let me know atleast how to call email-ext.

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, I don't know what does it mean email-ext plugin is not being called. I'm sure you might have gone through the project config.xml i have attached earlier. and it is clearly shows email-ext plugin is configured with equird fiels. If you still feel I have missed something in configuration please let me know. Appreciated if you let me know atleast how to call email-ext. Regards, Manoj
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          One small observation.
          The email-ext works fine for different free-style project on same Jenkins.

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, One small observation. The email-ext works fine for different free-style project on same Jenkins. Regards, Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          Sounds like the build flow job type is not running the publishers.

          Show
          slide_o_mix Alex Earl added a comment - Sounds like the build flow job type is not running the publishers.
          Hide
          manojoshi Manoj Kumar added a comment -

          Anything additional plugin or any setup configuration to be done?

          Show
          manojoshi Manoj Kumar added a comment - Anything additional plugin or any setup configuration to be done?
          Hide
          slide_o_mix Alex Earl added a comment -

          I'm not familiar with build flow, so I'm not sure.

          Show
          slide_o_mix Alex Earl added a comment - I'm not familiar with build flow, so I'm not sure.
          Hide
          manojoshi Manoj Kumar added a comment -

          np. thanks.

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - np. thanks. Regards, Manoj
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          if possible can you please assign it some one who can help me on Build flow..

          Thanks
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, if possible can you please assign it some one who can help me on Build flow.. Thanks Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          I already did

          Show
          slide_o_mix Alex Earl added a comment - I already did
          Hide
          manojoshi Manoj Kumar added a comment -

          Thanks.

          Show
          manojoshi Manoj Kumar added a comment - Thanks.
          Hide
          manojoshi Manoj Kumar added a comment -

          Hi Alex,

          If you cannot provide solution, never mind.
          Please don't alter the issue i have logged.

          If at all you want to modify at least assign it to proper components category.

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Hi Alex, If you cannot provide solution, never mind. Please don't alter the issue i have logged. If at all you want to modify at least assign it to proper components category. Regards, Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          I removed the email-ext component since the issue is not with email-ext. This is a common practice.

          Show
          slide_o_mix Alex Earl added a comment - I removed the email-ext component since the issue is not with email-ext. This is a common practice.
          Hide
          manojoshi Manoj Kumar added a comment -

          Not sure how this will effect. But my earlier problem was on Email-ext plugin + Bluid flow plugin.
          The Buildflow project was not sending mails after build completion.

          Regards,
          Manoj

          Show
          manojoshi Manoj Kumar added a comment - Not sure how this will effect. But my earlier problem was on Email-ext plugin + Bluid flow plugin. The Buildflow project was not sending mails after build completion. Regards, Manoj
          Hide
          slide_o_mix Alex Earl added a comment -

          Based on the build log you provided, the build flow plugin is not initiating the email-ext plugin.

          Show
          slide_o_mix Alex Earl added a comment - Based on the build log you provided, the build flow plugin is not initiating the email-ext plugin.
          Hide
          thomaste stefan thomasson added a comment -

          Not sure, but try enabling the workspace.
          <buildNeedsWorkspace>false</buildNeedsWorkspace>

          Show
          thomaste stefan thomasson added a comment - Not sure, but try enabling the workspace. <buildNeedsWorkspace>false</buildNeedsWorkspace>
          Hide
          ganeshpr Ganesh Murthy added a comment -

          I see the same for Build other projects and even trigger parameterized build plugin in post build actions. Does this mean, none of the post build actions are triggered when using a Build flow job type?

          Show
          ganeshpr Ganesh Murthy added a comment - I see the same for Build other projects and even trigger parameterized build plugin in post build actions. Does this mean, none of the post build actions are triggered when using a Build flow job type?
          Hide
          slide_o_mix Alex Earl added a comment -

          I have never tried build-flow + other things in post build since all the parameterized triggering and so forth is done in the DSL for me.

          Show
          slide_o_mix Alex Earl added a comment - I have never tried build-flow + other things in post build since all the parameterized triggering and so forth is done in the DSL for me.
          Hide
          thomaste stefan thomasson added a comment - - edited

          I have tested "Build other projects" and at least that is not executed unless "Flow run needs a workspace" is checked. And this seem to be the case for all post build actions.

          Show
          thomaste stefan thomasson added a comment - - edited I have tested "Build other projects" and at least that is not executed unless "Flow run needs a workspace" is checked. And this seem to be the case for all post build actions.
          Hide
          olivergondza Oliver Gondža added a comment -

          It seems that Flow run needs a workspace should be turned on automatically if there are any publisher to avoid this confusion.

          Show
          olivergondza Oliver Gondža added a comment - It seems that Flow run needs a workspace should be turned on automatically if there are any publisher to avoid this confusion.
          Hide
          lvotypkova Lucie Votypkova added a comment -

          I agree with Oliver. After update, jobs with post build steps stopped working and it took some time to realize it - because build did not fail. User should be at least warned because there is no sense to have post-build steps without "Flow run needs a workspace".

          Show
          lvotypkova Lucie Votypkova added a comment - I agree with Oliver. After update, jobs with post build steps stopped working and it took some time to realize it - because build did not fail. User should be at least warned because there is no sense to have post-build steps without "Flow run needs a workspace".
          Hide
          lucagiove Luca Giovenzana added a comment - - edited

          I confirm that Flow run needs a workspace solve the issue!
          It's quite annoying as bug

          Show
          lucagiove Luca Giovenzana added a comment - - edited I confirm that Flow run needs a workspace solve the issue! It's quite annoying as bug

            People

            • Assignee:
              Unassigned
              Reporter:
              manojoshi Manoj Kumar
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated: