Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29754

stage with concurrency :1 can hang forever.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
      None
    • Environment:
      workflow 1.9-beta1
    • Similar Issues:

      Description

      create a workflow with the following DSL

      stage concurrency: 1, name: 'doit'
      node {
       sh 'sleep 600'
      }
      

      Start a build, then immediately start another build
      delete the first build by going to job/1/doDelete

      expected results
      the second build that was waiting for the first to finish the stage would progress

      actual results
      the second build is still waiting for the build #1 to finish - and this will never happen.

        Attachments

          Issue Links

            Activity

            teilo James Nord added a comment -

            subsequent jobs will build and will not wait for #2 to finish.

            it is also to be noted that you can not abort/kill #2 with the red "x" on the UI.

            Running: build
            Entering stage build
            Waiting for builds [1]
            Aborted by James Nord
            Aborted by James Nord
            Aborted by James Nord
            Aborted by James Nord
            Aborted by James Nord
            
            jglick Jesse Glick added a comment -

            Seems like a simple duplicate of JENKINS-28183.


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                teilo James Nord
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: