Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29897

Failed to record SCM polling Error

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi,
      System Info
      Jenkins ver. 1.472
      Subversion plugin - 2.4.5
      Subversion tagging plugin - 1.17
      svnkit - 1.6
      Jdk - 1.7

      I tried to upgrade svn tagging plugin to 1.17 from 1.16 and started getting following error. I even tried to revert back to 1.16 and still see the same error.

      Aug 11, 2015 6:48:38 PM hudson.triggers.SCMTrigger$Runner runPolling
      SEVERE: Failed to record SCM polling for hudson.model.FreeStyleProject@65bc3ae7[Test-Job-name]
      java.lang.NoSuchMethodError: hudson.model.AbstractProject.getLastBuild()Lhudson/model/AbstractBuild;
      at hudson.scm.SubversionSCM.compareRemoteRevisionWith(SubversionSCM.java:1348)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      at hudson.scm.SCM.poll(SCM.java:373)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1376)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:420)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:449)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)

        Attachments

          Activity

          Hide
          k2nakamura k2nakamura added a comment - - edited

          I no longer maintain the plugin, but version 1.18 seems to address some API compatibility issue.
          See JENKINS-25611.

          Show
          k2nakamura k2nakamura added a comment - - edited I no longer maintain the plugin, but version 1.18 seems to address some API compatibility issue. See JENKINS-25611 .
          Hide
          vasucherry99 Srinivas Jajou added a comment -

          I did try to revert back to the version 1.16 that was working before and I still see the error. Is there anything that I need to manually cleanup to get it back to where it was? If so what files/directories that I need to manually clean up?

          Show
          vasucherry99 Srinivas Jajou added a comment - I did try to revert back to the version 1.16 that was working before and I still see the error. Is there anything that I need to manually cleanup to get it back to where it was? If so what files/directories that I need to manually clean up?
          Hide
          k2nakamura k2nakamura added a comment -

          Please try 1.18 instead of rolling back to 1.16. 1.18 is the latest.

          Show
          k2nakamura k2nakamura added a comment - Please try 1.18 instead of rolling back to 1.16. 1.18 is the latest.
          Hide
          vasucherry99 Srinivas Jajou added a comment -

          Tried 1.18 as well. Same issue. What is the right combination of subversion plugin and svn-tag? I have subversion 2.4.5.

          Show
          vasucherry99 Srinivas Jajou added a comment - Tried 1.18 as well. Same issue. What is the right combination of subversion plugin and svn-tag? I have subversion 2.4.5.
          Hide
          vasucherry99 Srinivas Jajou added a comment -

          I had to disable Subversion tagging plugin in order to get away from the error. Will figure out later when the plug in is needed. Anyway we are on a very older version Jenkins and might need to upgrade the core to be able to compatible with latest plugins. Thanks for the quick response and I really appreciate.

          Show
          vasucherry99 Srinivas Jajou added a comment - I had to disable Subversion tagging plugin in order to get away from the error. Will figure out later when the plug in is needed. Anyway we are on a very older version Jenkins and might need to upgrade the core to be able to compatible with latest plugins. Thanks for the quick response and I really appreciate.
          Hide
          k2nakamura k2nakamura added a comment -

          I hope you can guess the correct plugin version from the History section in the page.
          Please identify the release date of the Jenkins version you're using, and pick up the plugin version before or after.

          https://wiki.jenkins-ci.org/display/JENKINS/Subversion+Tagging+Plugin

          Show
          k2nakamura k2nakamura added a comment - I hope you can guess the correct plugin version from the History section in the page. Please identify the release date of the Jenkins version you're using, and pick up the plugin version before or after. https://wiki.jenkins-ci.org/display/JENKINS/Subversion+Tagging+Plugin

            People

            • Assignee:
              k2nakamura k2nakamura
              Reporter:
              vasucherry99 Srinivas Jajou
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: