Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: m2release-plugin
    • Labels:
      None
    • Environment:
      Jenkins LTS 1.609.2, m2release-plugin v0.14.0, Maven 3.0.4, IBM JDK 1.6
    • Similar Issues:

      Description

      Triggering a release build with maven-release-plugin v2.5.2 fails:

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.5.2:prepare (default-cli) on project ah-test: Execution default-cli of goal org.apache.maven.plugins:maven-release-plugin:2.5.2:prepare failed: A required class was missing while executing org.apache.maven.plugins:maven-release-plugin:2.5.2:prepare: org.codehaus.plexus.util.xml.pull.EntityReplacementMap

        Attachments

          Activity

          ahammar Anders Hammar added a comment -

          It seems as this was something bad in the plugin. It works with the newly released v2.5.3.
          (There was a lengthy mail thread about one of the plugin's deps on the Maven dev list, which might be the cause for this issue.)


            People

            • Assignee:
              Unassigned
              Reporter:
              ahammar Anders Hammar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: