Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30119

"ERROR: svn: E155010: The node '/x/y/z' was not found. org.tmatesoft.svn.core.SVNException: svn: E155010: The node '/x/y/z' was not found." when building with no workspace

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: subversion-plugin
    • Environment:
      Jenkins ver. 1.593
      on RH6 (Red Hat Enterprise Linux Server release 6.5 (Santiago))

      using
      jdk1.8.0_45
      Subversion Plug-in 2.5.1 (SVN version set to 1.8)

      jenkins started directly; no reverse proxy or some such
    • Similar Issues:

      Description

      My job is configured with

      • "Repository depth" "immediates"
      • "Use SVN update as much as possible"

      When I start it without a workspace (very first run), I got:
      {{
      Started by user Martin Jost
      [EnvInject] - Loading node environment variables.
      Building on master in workspace /x/y/z Checking out a fresh workspace because Jenkins failed to detect the current workspace /x/y/z
      ERROR: svn: E155010: The node '/x/y/z' was not found.
      org.tmatesoft.svn.core.SVNException: svn: E155010: The node '/x/y/z' was not found.
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.wc17.db.SvnWcDbShared.readInfo(SvnWcDbShared.java:744)
      at org.tmatesoft.svn.core.internal.wc17.db.SvnWcDbShared.readInfo(SvnWcDbShared.java:553)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDb.readInfo(SVNWCDb.java:3558)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDb.readInfo(SVNWCDb.java:3527)
      at org.tmatesoft.svn.core.internal.wc17.SVNWCContext.nodeWalkChildren(SVNWCContext.java:1548)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgGetInfo.run(SvnNgGetInfo.java:80)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgGetInfo.run(SvnNgGetInfo.java:51)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgOperationRunner.run(SvnNgOperationRunner.java:20)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2485)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.parseSvnInfo(UpdateUpdater.java:126)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.getSvnCommandToUse(UpdateUpdater.java:88)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:131)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:991)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:972)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:948)
      at hudson.FilePath.act(FilePath.java:981)
      at hudson.FilePath.act(FilePath.java:959)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:897)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:833)
      at hudson.scm.SCM.checkout(SCM.java:484)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1265)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Cleaning local Directory .
      ...
      }}

      Then the job passed ("green"; no other problem visible)
      When I start the job another time, I didn't get the problem.
      After deleting the workspace, I got it again (as the message indicates)

        Attachments

          Activity

          Hide
          alexlombardi2 Alex Lombardi added a comment -

          I am running a windows service based setup of Jenkins 1.625 with the 2.5 version of the Subversion plugin, and am getting a similar issue.

          However, in my case I have determined the error occurs because when the plugin targets the root URL for our Subversion repo, which has a redirect to a different location, it craps out.

          Show
          alexlombardi2 Alex Lombardi added a comment - I am running a windows service based setup of Jenkins 1.625 with the 2.5 version of the Subversion plugin, and am getting a similar issue. However, in my case I have determined the error occurs because when the plugin targets the root URL for our Subversion repo, which has a redirect to a different location, it craps out.

            People

            • Assignee:
              Unassigned
              Reporter:
              martinjost Martin Jost
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: