Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30207

"no protocol: nullgithub-webhook/" right after installing the plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: github-plugin
    • Labels:
    • Environment:
      Jenkins 1.609.2
      GitHub plugin 1.13.0
    • Similar Issues:

      Description

      from a fresh install of Jenkins + GitHub plugin (and no custom configuration) we can find in the jenkins log repeatedly:

      Jenkins log
      
      Aug 29, 2015 1:39:40 PM hudson.triggers.SafeTimerTask run
      SEVERE: Timer task com.cloudbees.jenkins.Cleaner@4dbc176e failed
      org.jenkinsci.plugins.github.internal.GHPluginConfigException: Mailformed GH hook url in global configuration (no protocol: nullgithub-webhook/)
              at org.jenkinsci.plugins.github.config.GitHubPluginConfig.getHookUrl(GitHubPluginConfig.java:110)
              at com.cloudbees.jenkins.Cleaner.doRun(Cleaner.java:58)
              at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:51)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
              at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
              at java.lang.Thread.run(Thread.java:745)
      
      Aug 29, 2015 1:42:40 PM hudson.triggers.SafeTimerTask run
      SEVERE: Timer task com.cloudbees.jenkins.Cleaner@4dbc176e failed
      org.jenkinsci.plugins.github.internal.GHPluginConfigException: Mailformed GH hook url in global configuration (no protocol: nullgithub-webhook/)
              at org.jenkinsci.plugins.github.config.GitHubPluginConfig.getHookUrl(GitHubPluginConfig.java:110)
              at com.cloudbees.jenkins.Cleaner.doRun(Cleaner.java:58)
              at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:51)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
              at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
              at java.lang.Thread.run(Thread.java:745)
      
      Aug 29, 2015 1:45:40 PM hudson.triggers.SafeTimerTask run
      SEVERE: Timer task com.cloudbees.jenkins.Cleaner@4dbc176e failed
      org.jenkinsci.plugins.github.internal.GHPluginConfigException: Mailformed GH hook url in global configuration (no protocol: nullgithub-webhook/)
              at org.jenkinsci.plugins.github.config.GitHubPluginConfig.getHookUrl(GitHubPluginConfig.java:110)
              at com.cloudbees.jenkins.Cleaner.doRun(Cleaner.java:58)
      

        Attachments

          Activity

          lanwen Kirill Merkushev added a comment - - edited

          Will fix this message on non-configured url soon. Thanks for report

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kanstantsin Shautsou
          Path:
          src/main/java/com/cloudbees/jenkins/Cleaner.java
          src/main/java/org/jenkinsci/plugins/github/config/GitHubPluginConfig.java
          src/main/resources/org/jenkinsci/plugins/github/Messages.properties
          http://jenkins-ci.org/commit/github-plugin/80c83969d834f2a5a9e068de8f0dd22233095e77
          Log:
          Merge pull request #77 from lanwen/JENKINS-30207_fix

          [FIXES JENKINS-30207] Don't run cleaner if github plugin not manage hooks

          Compare: https://github.com/jenkinsci/github-plugin/compare/8791c2a668a9...80c83969d834

          integer Kanstantsin Shautsou added a comment -

          please try 1.13.1

          thomasleveil Thomas LEVEIL added a comment -

          I cannot reproduce the issue anymore with v1.13.1


            People

            • Assignee:
              integer Kanstantsin Shautsou
              Reporter:
              thomasleveil Thomas LEVEIL
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: