Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30265

Jenkins Plugin for WebSphere Deployer Not deploying to WAS85ND ( Remote deployment)

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The EAR is deployed, but it doesn't start.

      Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to updated artifact: Failure uploading archive to server
      at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:278)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1047)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:408)

      Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            Hide
            jbengoa Josu Bengoa added a comment -

            Although I used the IP at the WebSphere IP/DNS property, internaly it was using the host name, so I added it to the hosts file and everything worked.

            Show
            jbengoa Josu Bengoa added a comment - Although I used the IP at the WebSphere IP/DNS property, internaly it was using the host name, so I added it to the hosts file and everything worked.
            Hide
            gpeters Greg Peters added a comment -

            This is caused by the DNS/IP setting in the jenkins job. This setting should match the DNS name specified in the SSL cert that is used in cacerts (as specified in the plugin documentation)

            Show
            gpeters Greg Peters added a comment - This is caused by the DNS/IP setting in the jenkins job. This setting should match the DNS name specified in the SSL cert that is used in cacerts (as specified in the plugin documentation)
            Hide
            gpeters Greg Peters added a comment -

            Closing, duplicate of JENKINS-31450

            Show
            gpeters Greg Peters added a comment - Closing, duplicate of JENKINS-31450

              People

              • Assignee:
                gpeters Greg Peters
                Reporter:
                jbengoa Josu Bengoa
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: