Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30295

Mercurial changeset numbers no longer work with newer versions of email-ext-plugin

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: mercurial-plugin
    • Labels:
      None
    • Environment:
      Jenkins version 1.591
      Mercurial Plugin version 1.51
      Email Extension Plugin version 2.40.5 (upgraded from 2.34)
    • Similar Issues:

      Description

      Starting with version 2.40 of the Email Extension Plugin, it uses 'getCommitId' on the ChangeLogSet.Entry object to get the commit id. However, the Mercurial Plugin only provides this information through the MercurialChangeset.getRevision method, which the Email Extension Plugin used to access through reflection.

      This is breaking e-mail configurations that used to work with Email Extension Plugin version 2.34. Specifically, the problem is that the %r (revision) formatting option for the ${CHANGES} option no longer works and will always show as 'null'.

      I suspect that the %d (date) option might be broken for a similar reason, though I have not tested that: In this commit: https://github.com/jenkinsci/email-ext-plugin/commit/6453a56cdcc82d2d7f085e8dba9c2b7032cb112a the Email Extension Plugin seems to have been modified to use getTimeStamp instead of getDate, which is also not yet implemented by the MercurialChangeSet.

      I've put the priority on 'major' because the only workaround is to use an older version of the Email Extension Plugin, which is undesirable because a different functionality of older versions of the Email Extension Plugin is not working under Jenkins 1.591 (the ability to put information about failed unit tests in the e-mail).

        Attachments

          Issue Links

            Activity

            slide_o_mix Alex Earl added a comment -

            This needs to be fixed in the mercurial plugin, not email-ext.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/hudson/plugins/mercurial/MercurialChangeSet.java
            src/test/java/hudson/plugins/mercurial/MercurialRule.java
            src/test/java/hudson/plugins/mercurial/SCMTestBase.java
            http://jenkins-ci.org/commit/mercurial-plugin/8063cc0c601e1864528186b582bbd28da0dffd75
            Log:
            Merge pull request #74 from Siriah/master

            JENKINS-30295 Implement getCommitId and getTimestamp methods of ChangeLogSet.Entry

            Compare: https://github.com/jenkinsci/mercurial-plugin/compare/ef1b8369f99c...8063cc0c601e


              People

              • Assignee:
                siriah Iris Hupkens
                Reporter:
                siriah Iris Hupkens
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: