Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30320

SDL init failure, reason is: No available video device

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi
      I am facing problem "SDL init failure, reason is: No available video device" on Window 10 and linux mint 17.2.

      On Linux I just install fresh copy of Linux and Jenkins with android plugin , in addition KV Plugin sudo apt-get install cpu-checker.

      now when I run job I am getting this log

      Started by user anonymous
      Building in workspace /home/jenkins/workspace/emulatorTest
      $ /home/jenkins/tools/android-sdk/tools/android list target
      [android] Using Android SDK: /home/jenkins/tools/android-sdk
      [android] Creating Android AVD: /home/jenkins/workspace/emulatorTest/.android/avd/hudson_en-US_640_WXGA720_android-23_tdsltest1.avd
      [android] /home/jenkins/tools/android-sdk/tools/android create avd -f -a -s WXGA720 -n hudson_en-US_640_WXGA720_android-23_tdsltest1 -t android-23
      $ /home/jenkins/tools/android-sdk/platform-tools/adb start-server
      * daemon not running. starting it now on port 8297 *
      * daemon started successfully *
      $ /home/jenkins/tools/android-sdk/platform-tools/adb start-server
      $ /home/jenkins/tools/android-sdk/tools/emulator -snapshot-list -no-window -avd hudson_en-US_640_WXGA720_android-23_tdsltest1
      [android] Starting Android emulator and creating initial snapshot
      $ /home/jenkins/tools/android-sdk/tools/emulator -ports 8295,8296 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_640_WXGA720_android-23_tdsltest1 -no-snapshot-load -no-snapshot-save -wipe-data
      *{color:red}SDL init failure, reason is: No available video device{color}*
      [android] Emulator did not appear to start; giving up
      $ /home/jenkins/tools/android-sdk/platform-tools/adb disconnect localhost:8296
      [android] Stopping Android emulator
      $ /home/jenkins/tools/android-sdk/platform-tools/adb kill-server
      Finished: NOT_BUILT
      

      If I am running same commands from terminal it is working fine but in Jenkins I am getting error

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              orrc Christopher Orr
              Reporter:
              kirshan kirshan luhana
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: