Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3046

Updated relevant Jira issues causing the build to fail

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: jira-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hi,
      Updated relevant Jira issues causing the build to fail with the following errors.
      ==============================================
      FATAL: ; nested exception is:
      org.xml.sax.SAXException: Invalid element in
      hudson.plugins.jira.soap.RemoteIssue - assigneeObj
      AxisFault
      faultCode:

      {http://schemas.xmlsoap.org/soap/envelope/}

      Server.userException
      faultSubcode:
      faultString: org.xml.sax.SAXException: Invalid element in
      hudson.plugins.jira.soap.RemoteIssue - assigneeObj
      faultActor:
      faultNode:
      faultDetail:

      {http://xml.apache.org/axis/}

      stackTrace:org.xml.sax.SAXException: Invalid
      element in hudson.plugins.jira.soap.RemoteIssue - assigneeObj
      at
      org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258)
      at
      org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035)
      at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
      at
      org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
      at
      org.apache.axis.encoding.DeserializerImpl.startElement(DeserializerImpl.java:369)
      at
      org.apache.axis.encoding.ser.BeanDeserializer.startElement(BeanDeserializer.java:154)
      at
      org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1048)
      at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
      at
      org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
      at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236)
      at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384)
      at org.apache.axis.client.Call.invoke(Call.java:2467)
      at org.apache.axis.client.Call.invoke(Call.java:2366)
      at org.apache.axis.client.Call.invoke(Call.java:1812)
      at
      hudson.plugins.jira.soap.JirasoapserviceV2SoapBindingStub.getIssue(JirasoapserviceV2SoapBindingStub.java:4537)
      at hudson.plugins.jira.JiraSession.getIssue(JiraSession.java:83)
      at hudson.plugins.jira.Updater.perform(Updater.java:93)
      at hudson.plugins.jira.JiraIssueUpdater.perform(JiraIssueUpdater.java:24)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:363)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:477)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:336)
      at hudson.model.Run.run(Run.java:886)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:229)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)

      {http://xml.apache.org/axis/}

      hostname:bdtools03

      org.xml.sax.SAXException: Invalid element in
      hudson.plugins.jira.soap.RemoteIssue - assigneeObj
      at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
      at org.apache.axis.client.Call.invoke(Call.java:2470)
      at org.apache.axis.client.Call.invoke(Call.java:2366)
      at org.apache.axis.client.Call.invoke(Call.java:1812)
      at
      hudson.plugins.jira.soap.JirasoapserviceV2SoapBindingStub.getIssue(JirasoapserviceV2SoapBindingStub.java:4537)
      at hudson.plugins.jira.JiraSession.getIssue(JiraSession.java:83)
      at hudson.plugins.jira.Updater.perform(Updater.java:93)
      at hudson.plugins.jira.JiraIssueUpdater.perform(JiraIssueUpdater.java:24)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:363)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:477)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:336)
      at hudson.model.Run.run(Run.java:886)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:229)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: org.xml.sax.SAXException: Invalid element in
      hudson.plugins.jira.soap.RemoteIssue - assigneeObj
      at
      org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258)
      at
      org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035)
      at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
      at
      org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
      at
      org.apache.axis.encoding.DeserializerImpl.startElement(DeserializerImpl.java:369)
      at
      org.apache.axis.encoding.ser.BeanDeserializer.startElement(BeanDeserializer.java:154)
      at
      org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1048)
      at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
      at
      org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
      at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236)
      at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384)
      at org.apache.axis.client.Call.invoke(Call.java:2467)

      =========================================================================

      Before the job throws out these exceptions and causing the build to fail, it
      actually succeeded remotely login to JIRA (via its SOAP API) and post comments,
      to note a build number that integrates the change.

      If I look at the build change log, it shows the Jira ID link to the Jira issues.
      Don't know why the build failed. Please help.

      Information:
      Jira Enterprise Edition v 3.11
      Hudson version 1.283 running under tomcat 6.0.18
      Operating system is Linux 4 Enterprise
      Job is an Java maven 2 build running against maven 2.0.9 binary
      JDK 1.6.0_12

      Regards,
      Hai

        Attachments

          Activity

          haiphan haiphan added a comment -

          Jira 3.11 - 3.13.2 using axis-1.3.jar, axis-jaxrpc-1.3.jar, axis-saaj-1.3.jar
          while axistools-maven-plugin-1.1-hudson-jira.jar using axis-1.4.jar,
          axis-jaxrpc-1.4.jar, axis-saaj-1.4.jar. I think this might be a main cause of
          the issues (version mismatch).
          Please help advise on the solution for this.
          Regards,
          Hai

          haiphan haiphan added a comment -

          Hello all,
          We are no longer experience this issue. Please close it out.

          Regards,
          Hai

          kutzi kutzi added a comment -

          I still experience this, if our JIRA server is temporarily down.

          I'm not sure if a non-available JIRA server should break the build, but my gut
          feeling says: no, it should save the JIRA issue status for the next build

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kutzi
          Path:
          trunk/hudson/plugins/jira/src/main/java/hudson/plugins/jira/Updater.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=25831
          Log:
          FIXED JENKINS-3046: error in JIRA plugin or if JIRA site is (temporarily) down shouldn't fail the build

          kutzi kutzi added a comment -

          Fixed in 1.18


            People

            • Assignee:
              kutzi kutzi
              Reporter:
              haiphan haiphan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: