Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30576

MSTestPublisher removed from job's config.xml when reloaded from disk

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: mstest-plugin
    • Labels:
    • Environment:
      Jenkins ver. 1.628
      Emma ver. 1.2.9
      MsTest plugin ver.0.19
      MsTestRunner plugin ver. 1.2.0
      Windows Server 2012
    • Similar Issues:

      Description

      When I go to "Manage Jenkins" and "Reload configuration from disk", the configuration for MsTestPublisher dissappears from the config.xml file for the job.

      We have established that the following block exists in the config.xml before hitting "Reload configuration from disk" but after reloading it's gone.

      <hudson.plugins.mstest.MSTestPublisher plugin="mstest@0.19">
        <testResultsFile>**/*.trx</testResultsFile>
        <buildTime>0</buildTime>
        <failOnError>true</failOnError>
        <keepLongStdio>true</keepLongStdio>
      </hudson.plugins.mstest.MSTestPublisher>
      

      We have other post-build steps defined in the configuration that remain in the file on configuration reloading, this particular one seems to be the only oddball.

        Attachments

          Activity

          nilleb Ivo Bellin Salarin added a comment -

          Hello Kjartan,

          Thanks for your feedback. I am not able to reproduce this issue neither in my test environment nor in the production one. Could you please have a look at the Jenkins logs, in order to see if some error has been logged?

          Thanks in advance,
          Ivo

          kjasva Kjartan Hjartarson added a comment - - edited

          Hi again,

          Had a look through jenkins.out.log, jenkins.err.log and jenkins.wrapper.log files as well as the logs available through the Jenkins GUI, and am unable to find any errors regarding MsTest, MsTestRunner, Emma or Junit plugins from around the time when we were setting up the configuration.

          Thanks,
          Kjartan.

          kjasva Kjartan Hjartarson added a comment -

          I tried uninstalling and reinstalling the MsTest plugin, restarted Jenkins and then tried reloading configuration from disc. Which fixed our problem.

          Thanks, and sorry for the inconvenience,
          Kjartan.


            People

            • Assignee:
              nilleb Ivo Bellin Salarin
              Reporter:
              kjasva Kjartan Hjartarson
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: