Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30661

Install without Maven plugin fails to install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: android-lint-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.609.1 installed on Fedora repo rpm
    • Similar Issues:

      Description

      The marked as optional dependency seems to be a required dependency. Install fails without the Maven plugin installed but succeeds after installation.

      From the updateCenter/ page:

      Android Lint Plugin
      Failure -
      java.io.IOException: Failed to dynamically deploy this plugin
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1322)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1121)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Failed to install android-lint plugin
      at hudson.PluginManager.dynamicLoad(PluginManager.java:473)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1318)
      ... 5 more
      Caused by: java.io.IOException: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:439)
      at hudson.PluginManager.dynamicLoad(PluginManager.java:464)
      ... 6 more
      Caused by: java.lang.NoClassDefFoundError: hudson/maven/AggregatableAction
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:760)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:796)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:674)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      at jenkins.util.AntClassLoader.findBaseClass(AntClassLoader.java:1397)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1074)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:760)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:796)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      at org.jenkinsci.plugins.android_lint.LintPlugin.start(LintPlugin.java:13)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:447)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:436)
      ... 7 more
      Caused by: java.lang.ClassNotFoundException: hudson.maven.AggregatableAction
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 37 more
      Maven Integration plugin Success
      Android Lint Plugin Success

        Attachments

          Activity

          orrc Christopher Orr added a comment -

          This plugin has a hard dependency on analysis-core, which in turn has always had a hard dependency on maven-plugin, so I'm not sure how you got into this situation.

          I just installed this plugin via the Update Center into a completely clean Jenkins 2.0 install, and the dependencies were correctly resolved:

          JUnit Plugin                          Success
          Javadoc Plugin                        Success
          Mailer Plugin                         Success
          Maven Integration plugin              Success
          Script Security Plugin                Success
          Matrix Project Plugin                 Success
          Static Analysis Utilities             Success
          Windows Slaves Plugin                 Success
          Icon Shim Plugin                      Success
          Matrix Authorization Strategy Plugin  Success
          OWASP Markup Formatter Plugin         Success
          Android Lint Plugin                   Success
          

            People

            • Assignee:
              orrc Christopher Orr
              Reporter:
              rcgroot René de Groot
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: