Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30800

Perfoce plugin fails to map all of the VCS roots in the mapping to slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Jenkins on Ubuntu LTS, client is a windows 2008 R2.
    • Similar Issues:

      Description

      if i have a view map with following mappings, the job always syncs the last one in the mapping and not all of the paths. a snap of the mapping is attached.
      //depot/server/main/a/... //workspace/a/...
      //depot/server/main/b/... //workspace/b/...
      //depot/server/main/c/... //workspace/c/...
      //depot/server/main/d/... //workspace/d/...

        Attachments

          Activity

          Hide
          rpetti Rob Petti added a comment -

          Is that the actual mapping you are using?

          Show
          rpetti Rob Petti added a comment - Is that the actual mapping you are using?
          Hide
          rpetti Rob Petti added a comment -

          And have you tested the mapping outside of the perforce-plugin?

          Show
          rpetti Rob Petti added a comment - And have you tested the mapping outside of the perforce-plugin?

            People

            • Assignee:
              Unassigned
              Reporter:
              power_1510 Power man
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: