Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30857

Java 6 runtime compatibility broken in gerrit-trigger 2.15.1, 2.16

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: gerrit-trigger-plugin
    • Labels:
      None
    • Environment:
      Debian wheezy amd64
      openjdk-6-jre-headless 6b36-1.13.8-1~deb7u1
      jenkins 1.609.3
    • Similar Issues:

      Description

      Hello,

      The commit https://github.com/jenkinsci/gerrit-trigger-plugin/commit/a5d44ea9dc6b42de7aeb63371a42b607e4578fb2 references ReflectiveOperationException, which has been introduced in Java 1.7.

      Since the README.md file states that the plugin should be runtime compatible with Java 6, I think that this can be considered as a bug.

      Best regards,
      Alex

        Attachments

          Activity

            People

            • Assignee:
              rsandell rsandell
              Reporter:
              boeglin Alexandre Boeglin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: