Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30922

Publish Over SSH Plugin fails to load after updating to 1.633

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Environment:
    • Similar Issues:

      Description

      The plugin fails to load with changes in 1.633 version of Jenkins. Reverting back to .1632 the plugin loads without any issue.

      10/12/15 21:13:03:702 EDT] 00000067 ExtensionFind W Failed to instantiate Key[type=jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin$Descriptor, annotation=[none]]; skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) Error injecting constructor, java.lang.RuntimeException: java.lang.ClassNotFoundException: com.jcraft.jsch.Buffer
      at jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin$Descriptor.<init>(BapSshPublisherPlugin.java:85)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:65)
      at hudson.ExtensionFinder$GuiceFinder$FaultTolerantScope$1.get(ExtensionFinder.java:428)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:1005)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1051)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:1001)
      at hudson.ExtensionFinder$GuiceFinder._find(ExtensionFinder.java:390)
      at hudson.ExtensionFinder$GuiceFinder.find(ExtensionFinder.java:381)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:388)
      at hudson.ExtensionList.load(ExtensionList.java:349)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:287)
      at hudson.ExtensionList.iterator(ExtensionList.java:156)
      at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1222)
      at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:152)
      at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:403)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$8.runTask(Jenkins.java:915)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1157)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:627)
      at java.lang.Thread.run(Thread.java:809)
      Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: com.jcraft.jsch.Buffer
      at org.kohsuke.asm5.ClassWriter.getCommonSuperClass(ClassWriter.java:1684)
      at org.kohsuke.asm5.ClassWriter.getMergedType(ClassWriter.java:1654)
      at org.kohsuke.asm5.Frame.merge(Frame.java:1426)
      at org.kohsuke.asm5.Frame.merge(Frame.java:1325)
      at org.kohsuke.asm5.MethodWriter.visitMaxs(MethodWriter.java:1475)
      at org.kohsuke.asm5.tree.MethodNode.accept(MethodNode.java:833)
      at org.kohsuke.asm5.commons.JSRInlinerAdapter.visitEnd(JSRInlinerAdapter.java:187)
      at org.kohsuke.asm5.MethodVisitor.visitEnd(MethodVisitor.java:877)
      at org.kohsuke.asm5.ClassReader.readMethod(ClassReader.java:1021)
      at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:693)
      at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:506)
      at org.jenkinsci.bytecode.Transformer.transform(Transformer.java:76)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:800)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:741)
      at java.lang.ClassLoader.defineClassImpl(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:331)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1139)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:801)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:741)
      at java.lang.ClassLoader.defineClassImpl(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:331)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1139)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:801)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:741)
      at java.lang.Class.getDeclaredFieldsImpl(Native Method)
      at java.lang.Class.getDeclaredFields(Class.java:817)
      at com.thoughtworks.xstream.mapper.AnnotationMapper.processTypes(AnnotationMapper.java:216)
      at com.thoughtworks.xstream.mapper.AnnotationMapper.processAnnotations(AnnotationMapper.java:182)
      at com.thoughtworks.xstream.mapper.AnnotationMapper.defaultImplementationOf(AnnotationMapper.java:141)
      at hudson.util.xstream.MapperDelegate.defaultImplementationOf(MapperDelegate.java:59)
      at com.thoughtworks.xstream.mapper.MapperWrapper.defaultImplementationOf(MapperWrapper.java:46)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:54)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1189)
      at hudson.util.XStream2.unmarshal(XStream2.java:113)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1173)
      at hudson.XmlFile.unmarshal(XmlFile.java:163)
      at hudson.model.Descriptor.load(Descriptor.java:783)
      at jenkins.plugins.publish_over_ssh.descriptor.BapSshPublisherPluginDescriptor.<init>(BapSshPublisherPluginDescriptor.java:68)
      at jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin$Descriptor.<init>(BapSshPublisherPlugin.java:85)
      at jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin$Descriptor$$FastClassByGuice$$c0ccaf36.newInstance(<generated>)
      at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40)
      at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:61)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:108)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:88)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:269)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1058)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      ... 24 more

        Attachments

          Issue Links

            Activity

            fred019 P. Fred added a comment -

            Same Problem,
            the plugin fails to load with changes in 1.633 version of Jenkins. Reverting back to .1632 the plugin loads without any issue.

            teilo James Nord added a comment -

            duplicate of JENKINS-30820


              People

              • Assignee:
                Unassigned
                Reporter:
                bcoveny Bruce Coveny
              • Votes:
                17 Vote for this issue
                Watchers:
                22 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: