Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31018

backward compatibility is broken in 1.7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: htmlpublisher-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.633
      CentOS 6.6
    • Similar Issues:

      Description

      Previously I was using plugin to handle few files in one report.
      The config is :
      HTML directory to archive = target/html-reports
      Index page[s] = report.html,results.txt
      Report title = TestReport
      Keep past HTML reports= true
      Always link to last build = false
      Allow missing report=true

      After upgrade to 1.7
      The report doesn't handle those files and displays no tabs at all. See attached screenshot.
      No warning was in job console output.

        Attachments

        1. config.png
          config.png
          80 kB
        2. config.xml
          1 kB
        3. filesystem.png
          filesystem.png
          55 kB
        4. HTML_ISSUES.png
          HTML_ISSUES.png
          2 kB
        5. htmlpublishconfig.png
          htmlpublishconfig.png
          11 kB
        6. htmlPublisher.png
          htmlPublisher.png
          23 kB
        7. jenkinsworkspacereport.png
          jenkinsworkspacereport.png
          9 kB
        8. report.png
          report.png
          44 kB

          Activity

          notanother Tim McNally added a comment -

          Also getting this in our Jenkins system after the update to 1.7.
          Here is the configuration that was working prior to the update:

          mcrooney mcrooney added a comment -

          Apologies, reverted in 1.8. I'll point the author to these issues and see if they can be resolved in a future patch while keeping file patterns

          fengtan Feng Tan added a comment -

          Well I am unable to reproduce this issue. I used the config described by Artem Yakovlev and Tim McNally with 1.7 and the files show up as expected in the report – see screenshots. I am also attaching the config.xml of the project I have locally, in case this rings a bell to someone.

          Artem Yakovlev Tim McNally would you mind telling us whether the files exist on your workspace ? For instance Artem Yakovlev, do $WORKSPACE/target/html-reports/report.html and $WORKSPACE/target/html-reports/results.txt exist ?
          Also can you confirm that upgrading to 1.8 resolves the problem ?
          If you have the config.xml of your projects handy, this might also be helpful.

          dr29bart Artem Yakovlev added a comment - - edited

          1.8 resolved the problem.
          All files exist, because I had to open them in workspace.

          notanother Tim McNally added a comment - - edited

          Both rolling back to 1.6 and upgrading to 1.8 fixed the issue. The files and folder exists in the workspaces.

          <publishers>
            <htmlpublisher.HtmlPublisher plugin="htmlpublisher@1.8">
              <reportTargets>
                <htmlpublisher.HtmlPublisherTarget>
                  <reportName>Sonarqube CSS Results</reportName>
                  <reportDir>sonar-css/issues-report</reportDir>
                  <reportFiles>issues-report-css.html</reportFiles>
                  <alwaysLinkToLastBuild>false</alwaysLinkToLastBuild>
                  <keepAll>true</keepAll>
                  <allowMissing>true</allowMissing>
                </htmlpublisher.HtmlPublisherTarget>
                <htmlpublisher.HtmlPublisherTarget>
                  <reportName>Sonarqube JS Results</reportName>
                  <reportDir>sonar-js/issues-report</reportDir>
                  <reportFiles>issues-report-js.html</reportFiles>
                  <alwaysLinkToLastBuild>false</alwaysLinkToLastBuild>
                  <keepAll>true</keepAll>
                  <allowMissing>true</allowMissing>
                </htmlpublisher.HtmlPublisherTarget>
              </reportTargets>
            </htmlpublisher.HtmlPublisher>
            <hudson.tasks.junit.JUnitResultArchiver plugin="junit@1.9">
              <testResults>unittests/cfcompile.xml</testResults>
              <keepLongStdio>false</keepLongStdio>
              <healthScaleFactor>1.0</healthScaleFactor>
            </hudson.tasks.junit.JUnitResultArchiver>
          </publishers>
          

            People

            • Assignee:
              mcrooney mcrooney
              Reporter:
              dr29bart Artem Yakovlev
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: