Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31150

Support Multiple SCM tags for rundeck notifier

    Details

    • Similar Issues:

      Description

      Currently you can provide a single scm tag in the "SCM Tag" post build rundeck notifier option. Sometimes you want to trigger the same rundeck job on different scm tags (e.g both #staging and #production tags will trigger the same rundeck job on the staging environment)

        Attachments

          Activity

          yurigo79 Yuri Goikhman created issue -
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Yuri Goikhman
          Path:
          src/main/java/org/jenkinsci/plugins/rundeck/RundeckNotifier.java
          src/test/java/org/jenkinsci/plugins/rundeck/RundeckNotifierTest.java
          http://jenkins-ci.org/commit/rundeck-plugin/3ddad7c59b29c6fd99b29aa1430f6aba6c8274ce
          Log:
          JENKINS-31150 - supporting multiple coma separated scm tags

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Yuri Goikhman
          Path:
          src/main/java/org/jenkinsci/plugins/rundeck/RundeckNotifier.java
          src/test/java/org/jenkinsci/plugins/rundeck/RundeckNotifierTest.java
          http://jenkins-ci.org/commit/rundeck-plugin/b20a96e5046ed751af9c0fdd5ec7e71d66ef6e7d
          Log:
          JENKINS-31150 - supporting multiple coma separated scm tags, aded tests

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Yuri Goikhman
          Path:
          src/test/java/org/jenkinsci/plugins/rundeck/RundeckNotifierTest.java
          http://jenkins-ci.org/commit/rundeck-plugin/2829e69510442dd25dfc232483a64a0b85883a50
          Log:
          JENKINS-31150 - supporting multiple coma separated scm tags, remove unnecessary imports from previous commit

          jringuette Joel Ringuette added a comment -

          This is not backward compatible as currently merged into master. See comments here https://github.com/jenkinsci/rundeck-plugin/pull/21#issuecomment-160143798

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: joel.ringuette
          Path:
          src/main/java/org/jenkinsci/plugins/rundeck/RundeckNotifier.java
          http://jenkins-ci.org/commit/rundeck-plugin/abf6f1dd9c6f4a7907cc47f43fb35ce8bf9ff7f1
          Log:
          Fix issues caused by JENKINS-31150 not being backward compatible.
          1 - NPE thrown when tags are stored under the old format.
          2 - Tags are not displayed in job configuration when reloaded under the new format.

          dserodio Daniel Serodio added a comment -

          Closing since https://github.com/jenkinsci/rundeck-plugin/pull/21 was merged and version 3.5.4 of the plugin released.

          dserodio Daniel Serodio made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 166329 ] JNJira + In-Review [ 197978 ]

            People

            • Assignee:
              yurigo79 Yuri Goikhman
              Reporter:
              yurigo79 Yuri Goikhman
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: