Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31151

scm-sync-configuration does not track promotions/config.xml

    Details

    • Similar Issues:

      Description

      When the plugin 'promoted-build' is installed, the files jobs/<job-name>/promotions/<promotion-name>/config.xml shall be archived

      Neither scm-sync-configuration nor thinBackup do currently backup these files

        Attachments

          Activity

          aeschbacher aeschbacher created issue -
          aeschbacher aeschbacher made changes -
          Field Original Value New Value
          Component/s thinBackup [ 15780 ]
          aeschbacher aeschbacher made changes -
          Environment scm-sync-configuration-plugin version 0.0.8
          scm-sync-configuration-plugin version 0.0.8
          thinBackup plugin
          aeschbacher aeschbacher made changes -
          Environment scm-sync-configuration-plugin version 0.0.8
          thinBackup plugin
          scm-sync-configuration-plugin version 0.0.8
          thinBackup plugin version 1.7.4
          aeschbacher aeschbacher made changes -
          Description When the plugin 'promoted-build' is installed, the files jobs/<job-name>/promotions/<promotion-name>/config.xml shall be archived

          This is currently not done
          When the plugin 'promoted-build' is installed, the files jobs/<job-name>/promotions/<promotion-name>/config.xml shall be archived

          Neither scm-sync-configuration nor thinBackup do currently backup these files
          oleg_nenashev Oleg Nenashev added a comment -

          Yes, seems these plugins are not compatible with the Data structure. I would recommend to create issues to them, because the issue is not limited to promoted-builds-plugin.

          Periodic Backup plugin supports supports such data format BTW

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 166331 ] JNJira + In-Review [ 182356 ]
          tofuatjava Thomas Fürer added a comment -

          with 1.8.0 it should be possible to specify additional backup relevant files
          so please try again, but don't hesidate to reopen the issue if it do not work for you

          tofuatjava Thomas Fürer made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]

            People

            • Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              aeschbacher aeschbacher
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: