Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31209

Make the length of the build description display user settable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:
    • Released As:
      2.198

      Description

      Right now, the build description gets truncated with ... at the end if too long. Would like to see two options in the configure jenkins screen:

      1. Truncate build description at (X) Beginning ( ) End
      2. Maximum length of build description to show in build history [ ]

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            To be honest, this looks like the kind of option mostly resulting in cluttered config pages that people complain about.

            thokari Thomas Hirsch added a comment -

            +1 for giving an option to not truncate the description.
            The problem here is that this description gets truncated on the server side. I strongly argue that this is something that should be handled exclusively by CSS, as doing so would completely cover this issue (and many others).
            Also I cannot see why this would need to be truncated in the first place. If the user puts in a lengthy description there, he probably has a rather valid reason to do so.
            In my case, it is the description of a MultiJob, and I want to display the branch names of two subprojects, as well as a URL that points to the QA system where the projects got deployed to.

            mibe Beer Michael added a comment - - edited

            +1 I use HTML code in the build description. The problem is that it uses raw text for the truncation, not the "real" used space. It would be great if we can modify the lenght of the build description.

            marty Marty S added a comment -

            I just ran into this myself.

            Also I think that HTML code such as links counts towards the maximum, which is annoying since I like to put quick-links into the description.

            slonopotamusorama Marat Radchenko added a comment -

            Fixed by https://github.com/jenkinsci/jenkins/pull/4209 and should be released in 2.198 next week. History widget no longer truncates build description.


              People

              • Assignee:
                Unassigned
                Reporter:
                nneul Nathan Neulinger
              • Votes:
                3 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: