Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3133

Logs incorrect when invoking multiple batch tasks after build

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: batch-task-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      First, thanks for creating the batch-task plugin. We have a lots of production
      and QA servers, and using it for deployment is huge for us!

      We use batch tasks to push product artifacts to several groups of servers. Thus,
      we commonly have several batch tasks configured for a project.

      When we run an automated nightly build, we use the "Invoke Batch Tasks of Other
      Projects" selection to kick off batch tasks after the build completes.

      With one selection things work fine. However, when we scheduled three items to
      run, things did not work correctly.

      Steps to reproduce:

      • configure a project with several batch tasks
      • configure the project to build on a schedule,
      • configure the project to "invoke batch tasks of other projects", and then
        use "add task" to invoke all three batch tasks

      Observed behavior:

      • when the project builds, it invokes all three batch tasks, according to the
        hudson log. In particular, ours looks like this:

      Total time: 6 minutes 47 seconds
      [locks-and-latches] Releasing all the locks
      [locks-and-latches] All the locks released
      Invoking CoLinx-WMS - CTNQA Everything #14-0
      Invoking CoLinx-WMS - CNVQA Everything #14-0
      Invoking CoLinx-WMS - CONQA Everything #14-0

      • We observed that the tasks all actually ran-- the problems is in display of
        the resulting logs
      • Observe that the numbers for the batch task number are not correct in the
        above log, all ending in "0"
      • We also observed that after the build, we see three links called "Executed
        TAsks" on the left nav bar of the project, instead of just one. clicking on any
        of the three links showed one task, intead of three. the link for each one
        appeared to be correct: http://hornet:8080/hudson/job/Colinx-WMS/14/batchTasks/
      • In the jobs folder, there was only one log file, not three, and it was
        titled "task-1.log".

      Expected Behavior:

      • one executed tasks link exists, and it links to a display showing three
        batch tasks, each with an available log on that page, and each with a task-#.log
        file in the jobs folder presumably.

      Thanks-- please do not hesitate to ask if I can clarify further

        Attachments

          Activity

          dcowden dcowden created issue -
          mindless Alan Harder made changes -
          Field Original Value New Value
          Assignee kohsuke [ kohsuke ] mindless [ mindless ]
          mindless Alan Harder made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          scm_issue_link SCM/JIRA link daemon made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          abayer Andrew Bayer made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 133206 ] JNJira + In-Review [ 201991 ]

            People

            • Assignee:
              mindless Alan Harder
              Reporter:
              dcowden dcowden
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: