Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31410

Flexible Publish plugin is waiting for previous builds to complete even if current build is already completed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      flexible pgublish - 0.15.2 , run condition - 1.0
    • Similar Issues:

      Description

      When two concurrent builds of same project are running (on two different nodes), if second build completes first, it is waiting for first build to complete before running the flexible publish logic.

      I see a message like "Flexible publish is waiting for a checkpoint on appbuild #3557_remotes/origin/master" in 3558 build. This is unnecessarily delaying the builds from completion.

        Attachments

          Activity

          ikedam ikedam added a comment -

          It's not a bug.
          Some post-build steps require the last build finished.
          Flexible-publish also requires that when embedding those post-build steps.
          And flexible-publish doesn't require that if none of embedded post-build steps require that.


            People

            • Assignee:
              ikedam ikedam
              Reporter:
              killerqa Praveen Kasireddy
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: