Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31603

"Error communicating to server! Server Error" in Delivery Pipeline IF Maven Integration disabled AND Static Analysis Utilities enabled

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      - Clean Jenkins 1.625.2 install running as a service on localhost:8080
      - Windows 7 and 10 x64 (using Windows installer)
      - Delivery Pipeline 0.9.7
      - Maven Integration Plugin 2.7.1 and 2.12.1
      - Static Analysis Utilities 1.74
    • Similar Issues:

      Description

      I have a very strange bug to report.

      The message "Error communicating to server! Server Error" will appear in the Delivery Pipeline view if:

      • the Maven Integration plugin is disabled and
      • the Static Analysis Utilities plugin is enabled and
      • the job displayed in the Delivery Pipeline has at least one build.

      Reproduction steps :

      • Start from clean install
      • Install Static Analysis Utilities plugin
      • Install Delivery Pipeline plugin
      • Create a new Freestyle job
      • Add a Delivery Pipeline view and assign it to the job
      • Right now, the pipeline works perfectly well, you can build the job as many times as you want and it will display properly in the pipeline (image 1)
      • However, if you disable the Maven Integration plugin, you will encounter the error message (only if you built the job at least ONCE, else nothing happens) (image 2)
      • If after disabling the Maven Integration plugin, you also disable the Static Analysis Utilities plugin, then it works again.

      Note that:

      • the Static Analysis Utilities plugin is an OPTIONAL dependency of the Delivery Pipeline plugin
      • the Maven Integration plugin is an OPTIONAL dependency of the Static Analysis Utilities plugin

        Attachments

          Issue Links

            Activity

            nicolass Nicolas S added a comment - - edited

            I don't think this is a duplicate of the issue JENKINS-21268 linked above.
            The linked issue appears to deal with build.xml not being created, but they do in my case.
            Past build history is still present in jobs, unlike the issue above.

            drulli Ulli Hafner added a comment - - edited

            Well, if the error still is present if the maven plug-in is enabled, then we have a different issue. (The static analysis suite will not work when the maven plug-in is disabled. There are exceptions from the class loader that might be hidden by the delivery pipeline plug-in)

            nicolass Nicolas S added a comment -

            Situation:

            • Delivery Pipeline is installed
            • Delivery Pipeline view MyView for a job MyJob

            Case 1:

            • Maven Integration enabled
            • Static Analysis Suite enabled
            • MyJob buils successfully, build.xml is created, build history is present
            • MyView works as expected

            Case 2:

            • Maven Integration enabled
            • Static Analysis Suite disabled
            • MyJob buils successfully, build.xml is created, build history is present
            • MyView works as expected

            Case 3:

            • Maven Integration disabled
            • Static Analysis Suite disabled
            • MyJob buils successfully, build.xml is created, build history is present
            • MyView works as expected

            Case 4:

            • Maven Integration disabled
            • Static Analysis Suite enabled
            • MyJob buils successfully, build.xml is created, build history is present
            • MyView does not work as expected

            I understand you said that Static Analysis Suite will not work with Maven Integration disabled. In that case I understand your position of having this as a duplicate of JENKINS-21268. In my case the build history is totally fine, and build.xml are created without problem (there are no missing builds of any kind, unlike the other issues related to JENKINS-21268). But perhaps the root cause is actually the same, if we assume that missing build.xml are only a byproduct of build steps having a dependency on Static Analysis Suite, and failing due to the interaction between Static Analysis Suite and Maven Integration.

            If my reading is right, the root cause of all the JENKINS-21268 related issues is what you said, namely that Static Analysis Suite can not work without Maven Integration. Is this correct?

            If yes, I think that the Maven Integration plugin should not be flagged as an optional dependency for Static Analysis Suite. Either that, or if it can work without Maven Integration, but Delivery Pipeline uses the optional dependency Static Analysis Suite in a way that requires Maven Integration, it should be stated somewhere.

            drulli Ulli Hafner added a comment -

            Yes, this marking the dependency as required is a workaround until I fix the root cause.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                nicolass Nicolas S
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: