Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31619

java.lang.NoClassDefFoundError: Could not initialize class net.bull.javamelody.I18N (with a non-default JENKINS_HOME)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Incomplete
    • Component/s: monitoring-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.625.1
      Monitoring 1.57.0
    • Similar Issues:

      Description

      Nov 16, 2015 6:54:59 AM net.bull.javamelody.JavaLogger warn
      WARNING: exception while collecting data
      java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: Could not initialize class net.bull.javamelody.I18N
              at hudson.remoting.Channel$2.adapt(Channel.java:810)
              at hudson.remoting.Channel$2.adapt(Channel.java:805)
              at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
              at net.bull.javamelody.RemoteCallHelper.collectDataByNodeName(RemoteCallHelper.java:169)
              at net.bull.javamelody.RemoteCallHelper.collectJavaInformationsListByName(RemoteCallHelper.java:179)
              at net.bull.javamelody.NodesCollector.collectWithoutErrorsNow(NodesCollector.java:154)
              at net.bull.javamelody.NodesCollector.collectWithoutErrors(NodesCollector.java:143)
              at net.bull.javamelody.NodesCollector$1.run(NodesCollector.java:87)
              at java.util.TimerThread.mainLoop(Timer.java:555)
              at java.util.TimerThread.run(Timer.java:505)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class net.bull.javamelody.I18N
              at net.bull.javamelody.RemoteCallHelper$DelegatingTask.call(RemoteCallHelper.java:130)
              at hudson.remoting.UserRequest.perform(UserRequest.java:121)
              at hudson.remoting.UserRequest.perform(UserRequest.java:49)
              at hudson.remoting.Request$2.run(Request.java:326)
              at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
              at java.util.concurrent.FutureTask.run(FutureTask.java:262)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
              at java.lang.Thread.run(Thread.java:745)
              at ......remote call to master_git(Native Method)
              at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1413)
              at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
              at hudson.remoting.Channel$2.adapt(Channel.java:808)
              ... 9 more
      

      seems to have started happening after an upgrade from an old version of both jenkins and the plugin

        Attachments

          Activity

          joshiadi Aditya Joshi added a comment -

          Thanks Tomasz for reopening the bug. When I installed the plugin after creating empty, writable $HOME/.jenkins/cache/jars, I received this error message:

          WARNING: exception while collecting data
          java.util.concurrent.ExecutionException: java.lang.Error: Unable to load resource JAVAMELODY-VERSION.properties
          	at hudson.remoting.Channel$2.adapt(Channel.java:810)
          	at hudson.remoting.Channel$2.adapt(Channel.java:805)
          	at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
          	at net.bull.javamelody.RemoteCallHelper.collectDataByNodeName(RemoteCallHelper.java:174)
          	at net.bull.javamelody.RemoteCallHelper.collectJavaInformationsListByName(RemoteCallHelper.java:184)
          	at net.bull.javamelody.NodesCollector.collectWithoutErrorsNow(NodesCollector.java:154)
          	at net.bull.javamelody.NodesCollector.collectWithoutErrors(NodesCollector.java:143)
          	at net.bull.javamelody.NodesCollector$1.run(NodesCollector.java:87)
          	at java.util.TimerThread.mainLoop(Timer.java:555)
          	at java.util.TimerThread.run(Timer.java:505)
          Caused by: java.lang.Error: Unable to load resource JAVAMELODY-VERSION.properties
          	at hudson.remoting.RemoteClassLoader.findResource(RemoteClassLoader.java:397)
          	at java.lang.ClassLoader.getResource(ClassLoader.java:1147)
          	at java.net.URLClassLoader.getResourceAsStream(URLClassLoader.java:227)
          	at java.lang.Class.getResourceAsStream(Class.java:2098)
          	at net.bull.javamelody.Parameters.getJavaMelodyVersion(Parameters.java:404)
          	at net.bull.javamelody.Parameters.<clinit>(Parameters.java:47)
          	at net.bull.javamelody.I18N.<clinit>(I18N.java:41)
          	at net.bull.javamelody.RemoteCallHelper$DelegatingTask.call(RemoteCallHelper.java:131)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:121)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:49)
          	at hudson.remoting.Request$2.run(Request.java:326)
          	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          	at java.lang.Thread.run(Thread.java:745)
          	at ......remote call to busgf2111.us.oracle.com(Native Method)
          	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1413)
          	at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
          	at hudson.remoting.Channel$2.adapt(Channel.java:808)
          	... 9 more
          Caused by: java.util.concurrent.ExecutionException: java.io.IOException: Failed to write to /users/releng/.jenkins/cache/jars/33/BDC5E9E1DFFBEA6E4C6765CBACB1DD.jar
          	at hudson.remoting.AsyncFutureImpl.get(AsyncFutureImpl.java:75)
          	at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
          

          I found https://issues.jenkins-ci.org/browse/JENKINS-18578 and realized my $HOME was also custom, so:

          1. Uninstalled the plugin
          2. Emptied the content of $HOME/.jenkins/cache/jars, but did not delete the directory
          3. Restarted Jenkins passing -Duser.home=<non_default_home>
          4. Installed the monitoring plugin

          I see the following errors now in Jenkins logs:

          WARNING: exception while collecting data
          java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: hudson/remoting/JarCacheSupport$1
          	at hudson.remoting.Channel$2.adapt(Channel.java:810)
          	at hudson.remoting.Channel$2.adapt(Channel.java:805)
          	at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
          	at net.bull.javamelody.RemoteCallHelper.collectDataByNodeName(RemoteCallHelper.java:174)
          	at net.bull.javamelody.RemoteCallHelper.collectJavaInformationsListByName(RemoteCallHelper.java:184)
          	at net.bull.javamelody.NodesCollector.collectWithoutErrorsNow(NodesCollector.java:154)
          	at net.bull.javamelody.NodesCollector.collectWithoutErrors(NodesCollector.java:143)
          	at net.bull.javamelody.NodesCollector$1.run(NodesCollector.java:87)
          	at java.util.TimerThread.mainLoop(Timer.java:555)
          	at java.util.TimerThread.run(Timer.java:505)
          Caused by: java.lang.NoClassDefFoundError: hudson/remoting/JarCacheSupport$1
          	at hudson.remoting.JarCacheSupport.resolve(JarCacheSupport.java:61)
          	at hudson.remoting.ResourceImageInJar._resolveJarURL(ResourceImageInJar.java:85)
          	at hudson.remoting.ResourceImageInJar.resolve(ResourceImageInJar.java:42)
          	at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:248)
          	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
          	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
          	at java.lang.Class.getDeclaredMethods0(Native Method)
          
          
          byahia Bilel Yahia added a comment -

          Was there any update to this? We're running the latest LTS version (2.46.3) and monitoring plugin version 1.65.1.

          snippet from the log:

           

          WARNING: exception while collecting data
          java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: Could not initialize class net.bull.javamelody.I18N
          at hudson.remoting.Channel$2.adapt(Channel.java:862)
          at hudson.remoting.Channel$2.adapt(Channel.java:857)
          at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
          at net.bull.javamelody.RemoteCallHelper.collectDataByNodeName(RemoteCallHelper.java:173)
          at net.bull.javamelody.RemoteCallHelper.collectJavaInformationsListByName(RemoteCallHelper.java:183)
          at net.bull.javamelody.NodesCollector.collectWithoutErrorsNow(NodesCollector.java:154)
          at net.bull.javamelody.NodesCollector.collectWithoutErrors(NodesCollector.java:143)
          at net.bull.javamelody.NodesCollector$1.run(NodesCollector.java:87)
          at java.util.TimerThread.mainLoop(Timer.java:555)
          at java.util.TimerThread.run(Timer.java:505)
          Caused by: java.lang.NoClassDefFoundError: Could not initialize class net.bull.javamelody.I18N
          at net.bull.javamelody.RemoteCallHelper$DelegatingTask.call(RemoteCallHelper.java:131)
          at hudson.remoting.UserRequest.perform(UserRequest.java:153)
          at hudson.remoting.UserRequest.perform(UserRequest.java:50)
          at hudson.remoting.Request$2.run(Request.java:336)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          at java.util.concurrent.FutureTask.run(FutureTask.java:262)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          at java.lang.Thread.run(Thread.java:745)
          at ......remote call to Dart Vistagrok 001(Native Method)
          at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1545)
          at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
          at hudson.remoting.Channel$2.adapt(Channel.java:860)
          ... 9 more
          
          evernat evernat added a comment -

          Bilel Yahia, Tomasz Śniatowski

          Can you try the monitoring plugin v 1.68.0 ? (The I18N class was moved in another package.)

          evernat evernat added a comment -

          No response from the reporter, so closing as incomplete and supposing as fixed.

          tsniatowski Tomasz Śniatowski added a comment -

          Apologies, I missed the email update somehow. Anyway, I think this was simply an instance of JENKINS-18578, and it seems better now. If it comes up again I'll follow up in JENKINS-18578.


            People

            • Assignee:
              Unassigned
              Reporter:
              tsniatowski Tomasz Śniatowski
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: