Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31640

TRIGGERED_BUILD_RUN_COUNT doesn't properly update when you trigger many jobs with the same name

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      Ubuntu with latest updates for plugins and jenkins
    • Similar Issues:

      Description

      We just upgraded and I was excited to see the new TRIGGERED_BUILD_RUN_COUNT env vars however I am seeing a bug with them

      I have a MultiPlugin Job that has 1 phase and calls something like 45 jobs in that phase
      These jobs are ALL the same exact jenkins job, but I pass different parameters to them

      Everything goes well, but at the very end, when I look at the ENV vars, I am always short one or two in the
      TRIGGERED_BUILD_RUN_COUNT and the TRIGGERED_JOB_NAMES

      so those above will match, but they are short. You can see the other vars show 45 properly and the counts are right but these do not, which makes it hard for me to get the results from them since I am missing a build number. Are there any workarounds to this? I need to copy artifacts from these jobs so need these build numbers for the subjobs
      I attached all my env vars printout so you can see

        Attachments

          Activity

            People

            • Assignee:
              huybrechts huybrechts
              Reporter:
              lorelei Lorelei McCollum
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: